Major issues with Samsung 830 SSD on 2011 MBP-I thought these issues were fixed???

Discussion in 'MacBook Pro' started by technopimp, Jan 5, 2012.

  1. technopimp macrumors 6502a

    Joined:
    Aug 12, 2009
    #1
    Having been left with a very bad taste in my mouth earlier this year with all the SATA III/2011 MBP SSD issues, I had gone to greener pastures with a MBA. However, due to a recent deal I was able to score, I'm back in a 15" 2011 MBP (2.2 i7). Having read that a recent EFI update supposedly addressed the issues (and seeing positive results with the Samsung 830 series), I bought a 256GB model.

    I just got the MBP and SSD yesterday, and I'm disappointed to report that I'm having just as many issues (if not more) than I did earlier this year. I did a clean Lion install, and before doing anything else went through software update to make sure I got all the EFI and other updates. After doing that, I've had nothing but application crashes and kernel panics. It's to the point where I can barely boot it without having the dashboard client or something else crash. I can't even launch firefox (launch, crash...restart, crash, kernel panic, repeat as needed).

    Rebooting does not help. I did a verify/repair permissions on the SSD-nothing. Did both an SMC PRAM reset-nothing. Have not yet reinstalled Lion, but if it's anything like the troubles earlier this year that will not make a difference.

    The ONLY other thing not "stock" about the machine was the RAM-I put in an 8GB GSkill kit that I had on my old machine. I did see some threads that mentioned how RAM could cause some of these issues, but what I don't get is this RAM worked 100% flawlessly on my other 2011 MBP (with an Intel SSD). I've put the stock RAM back in to see what happens.

    Is there something else blatantly obvious I'm missing? Am I just destined not to run a SATA-III SSD in a MacBook Pro? I'm very frustrated and very disappointed, especially when I see so many "working flawlessly" threads around.

    I'd welcome any other suggestions for things to try or that I might have missed. Thanks.
     
  2. Makosuke macrumors 603

    Joined:
    Aug 15, 2001
    Location:
    The Cool Part of CA, USA
    #2
    I'm in the boat of having had glitchy 6G SSD performance in a 2011 MBP (17") prior to the recent firmware update, and it being 100% fixed after the firmware update. Mine isn't a Samsung drive (OWC), so the setup is a little different, but a few things I could think of that might be relevant:

    1) You didn't mention whether you made sure the firmware on the SSD is up to date. There is apparently at least one firmware update available for the 830 series, and I know that there are SSDs from other companies (OCZ, I think) that had trouble in Macs prior to a firmware bump. Couldn't hurt, if you haven't already tried it.

    2) You said you installed Lion then did the software updates. If you mean that you installed it on the SSD before updating the MBP firmware, it's entirely possible that the OS install ended up corrupt due to the not-yet-updated firmware, in which case no amount of fiddling is going to fix it. The only fix will be a full reinstall, and I'd be sure to wipe the partition map and start completely fresh while I was at it--that could have gotten hosed, too. (And again, if you haven't updated the SSD's firmware yet, do that before the reinstall--same thing could happen/be the cause.)

    3) Are you running the SSD in the hard drive bay, or the optical bay? If it's in the optical bay, OWC has said that while some MBPs have 3G only in the optical bay, those that do have 6G often have random glitches that aren't fixed by the firmware update. If you're in that club, no amount of firmware updating is going to fix the issue.

    4) Bum RAM--even if it worked in something else--is at least a possible cause, but it sounds like you're already testing that.
     
  3. onions macrumors member

    Joined:
    Aug 17, 2011
    #3

    i'm guessing the OP's issues are because of #3.
     
  4. Acejam2k macrumors regular

    Joined:
    Jul 16, 2008
    #4
    This sounds exactly like an issue I was having.

    I have a late-2011 15" 2.5 i7 MBP. I am also running a 256GB Samsung 830 in my main HDD bay.

    I never received kernel panics, but I did receive several crashes and application lockups. The culprit was my Corsair 16GB RAM kit. I tested the RAM several times with 10+ rounds of Memtest, and it passed 100%. However in real world use, the RAM was the cause. I figured this out by going back to stock RAM, and I never had another issue again.

    On the flip side, your 6G SSD MUST be in the main HDD bay. It cannot be in the optical bay, or else you will have issues exactly like the ones you are describing.

    ----------

    Where are you getting your information from? Link please.

    To the best of my knowledge, no Samsung 830 firmware updates have been released.
     
  5. cliffr39 macrumors newbie

    Joined:
    Feb 6, 2007
    #5
    They may be referring to this http://www.samsung.com/us/support/downloads/solid-state-drives/MZ-7PC256N/AM
    Looks like it just came out 3 days ago (ver. 3.1)

    I'm struggling between this 830 and the Crucial M4 so closely watching
     
  6. technopimp thread starter macrumors 6502a

    Joined:
    Aug 12, 2009
    #6
    1) I have not updated firmware on the drive. I searched last night and couldn't find any reference to a firmware upgrade, but I will look again.

    2) Have not yet tried a reinstall, however I'm not sure I 100% agree with you because the updates were to the MBP firmware/EFI, although I guess you can never be too sure how things talk to each other.

    3) No, I am not running it in the optical bay. I replaced the stock 750GB hard drive.

    4) I'm hoping this is the issue, since the OWC 8GB kit is only $50 and I'd rather swap that than an SSD.

    ----------

    Thank you for the link...I'm going to check this out.
     
  7. Makosuke macrumors 603

    Joined:
    Aug 15, 2001
    Location:
    The Cool Part of CA, USA
    #7
    Yes, the afore-linked 3.1 updater is what I was talking about on the firmware update. All it says is "Fixed minor bugs", but you never really know what that means.

    Well, if a firmware incompatibility was resulting in write corruption, then anything you installed on the drive prior to fixing the problem could, potentially, be corrupt.

    If, on the other hand, the problems are just with read corruption or other flakey performance, then it could cause crashes while still writing good data to disk, and you'd expect the problems to go away instantly after fixing the problem.

    In my case, I only saw stalls and slow performance, no actual data corruption in either direction, and therefore no app crashes/kernel panics. But then, I had a much milder form of the problem than some.

    Purely out of curiosity, I'm wondering why you're only interested in those over OWC's Electra? StorageReview benchmarked all three at about the same read speed, the OWC at somewhat higher write speeds than the Crucial and nearly double the performance of the 830, they all have the same warranty, and at least using Newegg prices the OWC is a few cents cheaper per GB even with 8GB more overprovisioning. All else being equal, I'm usually willing to pay a few bucks more for OWC products if I'm putting them in a Mac, since they're thoroughly tested with OSX on Apple hardware.

    I'm not saying there aren't good reasons, just wondering what makes Crucial/Samsung more appealing for reference.
     
  8. daneoni macrumors G4

    daneoni

    Joined:
    Mar 24, 2006
    #8
    That sucks. I've been running a Crucial M4 on my 2.2 i7 and it has been running flawlessly since last June...then again i'm still on Snow Leopard.

    *shrug*
     
  9. Ccrew macrumors 68020

    Joined:
    Feb 28, 2011
    #9
    Curious as to what the ram is. You said it was from an old machine, but what old machine?
     
  10. technopimp thread starter macrumors 6502a

    Joined:
    Aug 12, 2009
    #10
    It's a GSkill 2x4GB DDR3 kit. The "old" machine was also a 2011 MBP.
     
  11. Makosuke macrumors 603

    Joined:
    Aug 15, 2001
    Location:
    The Cool Part of CA, USA
    #11
    Leopard or Lion doesn't have anything to do with it, for what it's worth. I take it you've either got a 13" (which didn't have any problems from the start), or you're one of the lucky few (and there are some) whose larger systems ran well from the start.
     
  12. matt94gt macrumors member

    Joined:
    Jul 9, 2011
    Location:
    Victoria BC Canada
    #12
    I just got the samsung 830 series in my notebook today. No issues. Im running Crucial 8GIG ram.

    See my post here of some issues I am having though:
    http://forums.macrumors.com/showthread.php?t=1282090 (post #8)

    I have mine in the optical bay, why do you say it must be in the HDD bay? Its 128gig if that matters...???

    I have not upgraded any firmware for it, does anyone know where I can download an update for the 830 Series SSD? Tried that link posted above but it does not say a thing about firmware.

    Thanks
     
  13. Makosuke macrumors 603

    Joined:
    Aug 15, 2001
    Location:
    The Cool Part of CA, USA
    #13
    The reason depends entirely on the luck of the draw. In the 2011 MBPs, some of them have 3G SATA in the optical bay, and some, for some reason, have 6G. Those that have 3G work fine, of course, but if you've got a 6G SATA drive (like the 830) max speed is capped at about 300MB/s, which is well under the ~500MB/s good current-gen SSDs can pump out. (Of course, in most real-world situations, the actual benefit is negligible, but we're talking about performance tweaking here.) Phrased differently, if you want the most speed possible, this isn't the configuration you'll want.

    The potential issue, though, is in those MBPs that have 6G in the optical bay. According to OWC's testing, most non-13" MBPs with 6G in the optical bay display major performance problems if you actually put a 6G drive on that bus. While the recent firmware update to the MBPs fixed 6G performance on the main bus, it didn't help at all with those that have it in the optical bay.

    So, if you're in that unlucky category, a 6G SSD is going to behave badly on the optical bus. 13", again, apparently work perfectly for whatever reason, on both busses, even before the firmware update.

    (My personal experience was that mine doesn't have 6G on the optical bay, so I was running my OWC 6G Extreme SSD in the optical bay, at the half-speed penalty, until the firmware update, at which point I moved it to the main bay and got better max throughput.)

    If you go to the Software tab at that link, the first item is "Magician Software (Software) (ver.3.1)"; according to the description, if I'm reading right, this includes a firmware updater. Actually getting it to run without a PC handy may be challenging, though.
     
  14. daneoni macrumors G4

    daneoni

    Joined:
    Mar 24, 2006
    #14
    15"
     
  15. LimJK macrumors newbie

    Joined:
    Dec 14, 2011
    #15
    Current Firmware CXM01B1Q

    Hi,

    I just pulled out my 512GB Samsung 830 SSD from my MacBookPro 17" (Early 2011) and connect it to my Windows 7 Desktop to check out the recent updates on the Magician Software 3.1.

    What is new is that they provided an additional option to create a bootable CD/DVD (that Mac users need) in addition to the original Bootable USB solution that does not work on Mac.

    SSD FirmwareUpdateOptions.png

    I can confirm that the current Firmware is CXM01B1Q and there is no newer firmware at this point.

    The Magician software checks the presence of Samsung SDD before you can download firmware or create bootable CD ... so for us, Mac users we still need to pull out your SSD and attach it to a Windows Machine to update the firmware.

    I have been using this SSD with my MacBookPro for over 3 weeks, I have TRIM enabled (via terminal commands), it seems to be very well behave so far :)
     
  16. technopimp thread starter macrumors 6502a

    Joined:
    Aug 12, 2009
    #16
    Well, I ran all last night on the stock 4GB of RAM with no issues, crashes, or kernel panics. I'm going to run over the weekend and see what happens, but for now it's pointing to the memory. Just seems weird it would have worked fine in the other MBP of the same vintage.
     
  17. cliffr39 macrumors newbie

    Joined:
    Feb 6, 2007
    #17
    Well they are half way there I guess. Doesn't make sense that they don't make the magician a bootable cd instead so you don't have to pull the drive. But, good to see they are getting closer to Mac friendly.
     
  18. Acejam2k macrumors regular

    Joined:
    Jul 16, 2008
    #18
    I'm new to the Mac game, but I've been building high-end PC's for over 15 years. Based off my research and personal experience with my 16GB Corsair RAM kit failing, Mac's seem to be *extremely* sensitive to RAM.

    If the RAM is even remotely bad, all types of weird things will happen. On a PC, if you pass a few rounds of Memtest, 99% of the time, you're good to go. I passed 10 rounds on my 15" MBP with the Corsair 16GB kit, and my memory was still the culprit. I've been on the stock RAM for over a month now, and it's been rock solid.

    It was definitely the RAM for me, and it goes against my experience with PC's, but it is what it is. The Samsung 830 is an awesome drive!

    Protip: Install Windows 7 on a BootCamp partition and you won't have to take the drive out to update the firmware.
     
  19. Krazy Bill macrumors 68030

    Krazy Bill

    Joined:
    Dec 21, 2011
    #19
    My feeling is the memory sockets are just too fickle, at least in my Early 2011 MBP13. The modules just don't feel like they seat firmly to me. I had memory problems a few months ago and just reseated the RAM. It didn't go back in any differently to my eyes but all has been fine ever since. Go figure.
     
  20. archangel37 macrumors member

    Joined:
    Apr 1, 2005
    #20
    I can tell you my desire to go for the 830 after running lots of Electras. The Sandforce firmware. The Sandforce controller used by the Electras was (and depending on when you bought them, is) notorious for flaky firmware. In my case, it caused random lockups while running Windows 7. They've finally released a firmware that they say fixes the issues.

    Unfortunately, neither the Boot Camp/Windows firmware update software or Mac software that OWC provides works on any of my Mac minis. Their advice: send them the drives so they can update them. Gee, thanks, super helpful.

    I'll take the small drop in performance for the improved reliability. After all, Apple itself uses either Samsung or Toshiba SSDs. Cost can't be the only reason they do so.

     
  21. mpaquette macrumors regular

    Joined:
    Jul 15, 2010
    Location:
    Columbia, SC
    #21
    I just put a 256GB Samsung 830 in an early 2011 MBP. Aside from having some trouble getting Lion to install using the Internet recovery, I haven't had any issues. I did update the firmware to the latest version using the Samsung Magician before installing anything on it.
     
  22. technopimp thread starter macrumors 6502a

    Joined:
    Aug 12, 2009
    #22
    I'm thinking my issues were more RAM related now than SSD. I've been running on stock RAM for almost a month now and have not really had any issues other than the occasional beachball. Nowhere near the constant lockups and kernel panics when I first installed. I guess I might have "cried wolf" about the SSD, but it just didn't make any sense since I used the same 2 sticks of RAM in another MBP for 6 months with zero issues.
     
  23. mpaquette macrumors regular

    Joined:
    Jul 15, 2010
    Location:
    Columbia, SC
    #23
    That makes sense. I upgraded my RAM the same time I purchased my SSD, but I installed the RAM first and ran it with my stock Apple HD for a couple of weeks just to make sure it was working correctly. This way if I started having issues when I installed the SSD, I could be confident that it was the SSD and not the RAM.
     
  24. Acejam2k macrumors regular

    Joined:
    Jul 16, 2008
    #24
    I pretty much did the same thing when my issue occurred. I ended up RMA'ing the Corsair 16GB RAM kit back to NewEgg, and ordered a 16GB RAM kit direct from Crucial.

    I've been running the Crucial memory for about 2 weeks now. It was more $$, but well worth the piece of mind. (Crucial tests their RAM on Mac's) No lockups or crashes to date.
     
  25. angelofarina macrumors newbie

    Joined:
    Mar 13, 2012
    Location:
    Parma, ITALY
    #25
    So, the RAM can be the cause of trouble, instead of the SSD...
    One week ago, I also upgraded my 2012 MBP 17", installing simultaneously 16GB of RAM (Corsair DDR3 - CMSA16GX3M2A1333C9) and a 256GB SSD (Corsair Performance Pro, CSSD-P256GBP-BK).
    After a clean install of OSX Lion on the main partition, the system is completely unreliable, with very long stalls with the spinning wheel, and several complete crashes.
    The same day I mounted and identical SSD on my son's MBP 13" end 2009, and there everything is fine...
    Both drives were mounted in the main bay of these two machines.
    I was thinking that my SSD was bad (albeit passing with zero errors any available test both on the OSX and Win7 partitions), but this thread seems to suggest that the problem is the Corsair 16GB RAM (albeit being sold as "Mac compatible)...
    I am going to swap it with the original 4GB RAM, and see what happens. I will keep you informed...
    In the case, I will need to ask for replacement of the 16GB RAM kit. I fear it will not be easy, as the RAM works perfectly under Windows7...
    How can be that the same machine is stable under Windows 7 and not under Lion ???
     

Share This Page