Major Lion issue, please help

Discussion in 'Mac OS X Lion (10.7)' started by iGrainger, Sep 4, 2011.

  1. iGrainger macrumors member

    iGrainger

    Joined:
    Aug 31, 2010
    #1
    Hello.

    I'm a proud owner of a MacBook and an iMac, however, I'm going off to University next month and I decided I needed to install Windows 7 onto my iMac incase I need software on it for whatever reason.

    Now, I turned it on this morning and it came up with a black screen, saying 'No bootable device -- insert boot disk and press any key'

    I have installed Lion on both machines before, and I can't make a USB version of Lion to do something. Is there ANYTHING I can do? Lion is installed on the HD, and Windows is installed via VMWare Fusion.

    Something has utterly screwed up and I'm stressing out like mad, can anybody help me?
     
  2. chas0001 macrumors 6502a

    chas0001

    Joined:
    Sep 18, 2006
    Location:
    Alicante, SPAIN
    #2
    To boot into Lion again turn the computer off (hold power button until it goes off). Then power it on and hold down the ALT key on the keyboard. It should show a boot menu. Choose your Lion OS partition to boot from it (usually Macintosh HD).
     
  3. iGrainger thread starter macrumors member

    iGrainger

    Joined:
    Aug 31, 2010
    #3
    Hello, yeah, I've been trying that but i've got a wireless keyboard. It doesn't seem to be picking it up anymore!

    ----------

    Edit, Thanks that worked, but will that be sorted for future boot ups?

    ----------

    I just rebooted after I got back onto OS X, and it isn't loading OS X straight up. It goes back to the bootable error. When I choose between the OS, the only ones available were Macintosh HD and Recovery HD?

    ----------

    I just did a past tip I remembered holding down the Control button and clicking on the OS. Lion is now the default OS and loads up as it should do, apologies. Sorted now.
     
  4. chas0001 macrumors 6502a

    chas0001

    Joined:
    Sep 18, 2006
    Location:
    Alicante, SPAIN
    #4
    Sorry my mistake. I forgot to add the bit about going into system preferences and choosing the default boot disk.
     

Share This Page