Major Photos Bug (People)

Discussion in 'macOS Sierra (10.12)' started by theBigD23, Sep 15, 2016.

  1. theBigD23, Sep 15, 2016
    Last edited: Sep 15, 2016

    theBigD23 macrumors 6502a

    Joined:
    Sep 13, 2008
    #1
    Major issues with People where if you either click X on a face in any random picture to not show up in the People section or in the for People that have already a tagged face, it will show in the Add People section with a grey box and not a face. Continuous problems and potential data loss await. (You will see this for People with 1 picture or multiple pictures.) You cannot see the the persons face since it is greyed out and double clicking, right-clicking does nothing.

    If you do add a Person, it will still be the same grey screen on your main People page. If you do double-click, it will take you to the overview page with an pinwheel that does nothing and all areas of that page will be grey. I continued to let it go on and the pinwheel just stops, but nothing appears. (After repair, I saw that it is "analyzing", but nothing came of it) I was able to find the pictures if you play a Slideshow by right clicking. It will only then show you the affected pages. Going back, everything was grey again and I could not do anything.

    The part with the major issue: for one of the grey boxes with 8 pictures that I had added, you cannot remove the face. Just hide. I don't remember if it was before or after I hid the picture, but I could not add other faces at all. The adding Face button was gone. I tried repairing, but the Add Faces button was no longer there. I had to restore my Photos library, however, all that did was bring back the + Add People, but still left the grey box with 8 people. For some reason, even with a restore before I added the Grey face, it was still there in the main People section. I also continued to have grey boxes in the Add People section.

    There are three main bugs:
    1) grey pictures in the Add People section after X'ing out a Face and/or random pictures with greyed out Faces that were already tagged
    2) after adding a Face that is grey, I am not able to go to the Add Faces section (but was able to after restore)
    3) Even with deletion of affected pictures, deletion of face, the grey boxes will still remain in People. There's no way to get rid of this as far as I can see.

    An additional usability issue is that you cannot delete a Person, you can only Hide.

    Random notes roundup:
    -I can see the pictures by playing a slideshow
    -Removing the Face from the picture doesn’t fix anything
    -Deleting the picture does not do anything. The grey section is still in People.
    -There's no way to remove the affected grey boxes in People
     
  2. arilev macrumors member

    arilev

    Joined:
    Sep 7, 2004
    Location:
    Oakland, CA
    #2
    Same issue here and it's driving me insane. I actually posted a similar thread a few days ago but it didn't get any responses.

    One thing to add: The grey boxes DO disappear if a photo is deleted (i.e. Trash emptied) but...I submitted a bug report.
     
  3. theBigD23 thread starter macrumors 6502a

    Joined:
    Sep 13, 2008
    #3
    I hate to say it, but at least it's just not me. I updated to build 323 and nothing changed.

    I submitted to Apple too. Hopefully one of the point releases will fix this issue.

    I will also update that deleting from Trash does get rid of it. I did not empty trash, just deleted.

    I'm using iCloud Photo Library. Are you as well?
     
  4. arilev macrumors member

    arilev

    Joined:
    Sep 7, 2004
    Location:
    Oakland, CA
    #4
    I am using iCloud Photo Library but I've also tested by creating a brand new library that is not using iCloud Photo Library and get the same results. I'm also running 323 but first noticed this issue a couple of betas back (don't remember exactly which beta is was though).

    I guess the best we can hope for at this stage is a fix in 10.12.1...
     
  5. theBigD23 thread starter macrumors 6502a

    Joined:
    Sep 13, 2008
    #5
    Yes, looks like a point release is what we have to wait for. It's a pretty big bug. I hope others that have this issue also report it.

    At least when playing the Slideshow, we can still see the images. So the connection is there.
     
  6. arilev macrumors member

    arilev

    Joined:
    Sep 7, 2004
    Location:
    Oakland, CA
    #6
    As of this afternoon Apple Bug Reporter is showing my bug submission as a duplicate, but still open issue. That's progress...
     
  7. theBigD23 thread starter macrumors 6502a

    Joined:
    Sep 13, 2008
    #7
    Have you tried 10.12.1 and see if that fixes it? I'm unable to install right now.
     
  8. arilev macrumors member

    arilev

    Joined:
    Sep 7, 2004
    Location:
    Oakland, CA
    #8
    I'm taking a beta breather but I'm guessing that it's not resolved in 10.12.1 as Bug Reporter still indicates it as an open bug.
     
  9. theBigD23 thread starter macrumors 6502a

    Joined:
    Sep 13, 2008
    #9
    I just tested on 10.12.1 and I have the issue persists. Hopefully in the next version.
     
  10. arilev macrumors member

    arilev

    Joined:
    Sep 7, 2004
    Location:
    Oakland, CA
    #10
    Yep, still an open issue according to bugreport.apple.com
     
  11. megalaser macrumors 6502

    megalaser

    Joined:
    Nov 17, 2009
    #11
    Photos crashes if I try to import any photo - it's the duplicates checker, as soon as it kicks in it crashes photos.
     
  12. theBigD23 thread starter macrumors 6502a

    Joined:
    Sep 13, 2008
    #12
    I still have the issue in 10.12.2. :( Hopefully next release
     
  13. arilev macrumors member

    arilev

    Joined:
    Sep 7, 2004
    Location:
    Oakland, CA
    #13
    At this point I'm guessing that this doesn't get resolved until 10.13 and the hopeful (re)introduction of syncing People across devices.
     
  14. ButteryScrollin macrumors 6502a

    Joined:
    Jul 29, 2014
    #14
    I have this too.
    One thing I've found in 10.12.2... if you open the picture, you can select 'This Person is not in this photo' and it will remove it.
     
  15. theBigD23 thread starter macrumors 6502a

    Joined:
    Sep 13, 2008
    #15
    Looks like your 10.13 prediction is going to be correct. No fix in 10.12.3. It's a major bug. I do hope it is sooner.
     
  16. cynics macrumors G4

    Joined:
    Jan 8, 2012
    #16
    Definitely submit this to Apple. I havent ran into this issue nor do I want to try to recreate it by the sounds of it. Sorry.
     
  17. theBigD23 thread starter macrumors 6502a

    Joined:
    Sep 13, 2008
    #17
    I submitted to Apple and the case was closed since it was a duplicate. I have no insight into what's happening with this issue.
     
  18. ButteryScrollin macrumors 6502a

    Joined:
    Jul 29, 2014
  19. arilev macrumors member

    arilev

    Joined:
    Sep 7, 2004
    Location:
    Oakland, CA
    #19
    Still unresolved. Guessing we are waiting until 10.13 for resolution to this one.
     
  20. theBigD23 thread starter macrumors 6502a

    Joined:
    Sep 13, 2008
    #20
    My concern is that it won't be fixed and is a database issue that cannot be fixed. I really hope it gets fixed.
     
  21. arilev, Jan 25, 2017
    Last edited: Jan 25, 2017

    arilev macrumors member

    arilev

    Joined:
    Sep 7, 2004
    Location:
    Oakland, CA
    #21
    Seems like they are working on something related to Faces/People as it now impossible to remove an automatically detected face altogether in 10.12.4b1. Also now when I click into "Add People" and scroll up and down long enough Photos crashes consistently (never did that before).

    The optimist in me wants to say "I guess this is promising as it shows they are working on it" but the pessimist agrees with theBigD23 that this is a more problematic issue and therefore they are simply removing the ability to delete automatically detected faces. If that's the case (and we'll have to wait and see) then it still doesn't seem to solve the issue for those of us who are already stuck with all the empty gray boxes.
     
  22. cynics macrumors G4

    Joined:
    Jan 8, 2012
    #22
    Hmm.. Something similar is happening in iOS on my iPhone 6S and it immediately reminded me of this thread.

    I added a bunch of pictures to be tagged manually. However 2 of them show up gray. Clicking on them does nothing. Long pressing just shows a bigger gray box. I have no idea who these were pictures of and I can't remove them. Although I can "hide" them as if it was a person I didnt want to see.
     
  23. theBigD23 thread starter macrumors 6502a

    Joined:
    Sep 13, 2008
    #23
    Doesn't work for me still. As you said, may be fixed in the next OS. Huge issue though. I hope they do not ignore it.
     
  24. arilev macrumors member

    arilev

    Joined:
    Sep 7, 2004
    Location:
    Oakland, CA
    #24
    And to make matters even more annoying you can no longer remove unnamed faces at all.
     
  25. theBigD23 thread starter macrumors 6502a

    Joined:
    Sep 13, 2008
    #25
    That's annoying. As you said, we'll have to wait until 10.13
     

Share This Page