Major Problem - Please Help

Discussion in 'Mac Basics and Help' started by jbrown, Jun 3, 2009.

  1. jbrown macrumors 6502a

    jbrown

    Joined:
    Jul 7, 2002
    Location:
    London
    #1
    MacbookPro 2.4 Leopard 10.5.7

    I have a partition problem on my hard drive. I have a 160GB drive that I had partitioned in 90GB ( with system ) and 60GB ( with data ).

    What I wanted to do was to delete the 60GB partition so I would have a 150GB single partition. I backed up all my files on the 60GB partition, and using Disk Utility I clicked on the main drive icon - then 'Partition', and then the ' - ' to remove the partition. That worked fine.

    Still in Disk Utility, I enlarged the 90GB to fill the whole disk ( which it told me would be 150GB ) - all good and I then pressed 'Apply'.

    But it fails in this. My 90GB partion is unchanged ( and working fine ), but effectively I have 'lost' 60gb of hard disk space.

    Help please!!!!!:(:(:(
     
  2. misterredman macrumors 6502a

    misterredman

    Joined:
    Oct 3, 2007
    #2
    Did you try the same thing by booting from the install discs? I would also do a repair from there too.
     
  3. STXSTEVE macrumors member

    STXSTEVE

    Joined:
    Mar 9, 2009
    Location:
    Colorado
    #3
    First off make sure you have a backup of your OSX partition. I have heard of command line partition deletion but have never tried it... I was always under the impression if you want to get rid of and expand partitions the best way is to reinstall. I would back up you OSX partition with time Machine and do a new reinstall. Simpler and safer in my opinion..
     
  4. -tWv- macrumors 68000

    -tWv-

    Joined:
    May 11, 2009
    Location:
    Ohio
    #4
    I agree, I would back up the OSX volume and boot up from the install discs and erase and reformat the whole thing. Im pretty sure it has to be a Mac OSX Extended (Journaled) Volume.
     

Share This Page