iPhone Major Wifi Issues on iPhone X, IOS 11.2.5

Discussion in 'iOS 11' started by poseidondt, Feb 18, 2018.

  1. poseidondt macrumors newbie

    Joined:
    Feb 18, 2018
    #1
    Since 3 weeks i have major Wifi issues on my iPhone X; it automatically connects and disconnects, has bad reception; i was at the Apple Store, they thought it is a Hardware Issue and gave me a new iPhone X.
    I restored and guess what : same issue !
    I also restored to my iPhone 7, but have no problems;
    so either i was so lucky (unlucky) to have 2 phones with an Hardware error, or, something on my iPhone X restore makes my Wifi to fail.

    i attach a screeshot how it sometimes looks, showing wifi off, but still is on.....
     

    Attached Files:

  2. anubis1980 macrumors 6502

    Joined:
    Oct 22, 2012
    #2
    Does this only happen when connecting to 5ghz WiFi Channels.? A few posts state people have issues with 5 but connect fine on 2.4 . Mine included. I have had two phones as well with that same issue.
     
  3. MrTazz macrumors member

    MrTazz

    Joined:
    Sep 23, 2015
    #3
    I’m having the same problem, it says on connected but I’m not have to turn WiFi off then on again. How do you go about connecting to 2.4 only?
     
  4. anubis1980 macrumors 6502

    Joined:
    Oct 22, 2012
    #4
    Depends on your router , I’m in sky Q . You have to split the channels your router broadcasts it’s different for each one . If you google the router name it will tell you
     
  5. MrTazz macrumors member

    MrTazz

    Joined:
    Sep 23, 2015
    #5
    I have sky Q as well any chance you can tell me how to go about it ?!
     
  6. Phogro macrumors regular

    Phogro

    Joined:
    Aug 13, 2015
    Location:
    Boston, MA
    #6
    I've definitely noticed some issues with 5.0 WiFi over the last few weeks both on my X and my wife's. Haven't tried 2.4.
     
  7. anubis1980 macrumors 6502

    Joined:
    Oct 22, 2012
    #7
    It can affect any mini boxes you have so be careful tbh might be worth googling it for the official guide but from memory you need to login to the router from a browser by typing in 192.168.0.1 into the address bar.on the wireless tab under wireless access point is a synchronize 2.4 and 5 option . If you untick this should separate channels. Might ask you for a password all sky q I think are admin for username, password is sky.
    --- Post Merged, Feb 19, 2018 ---
    Mine has been duff on 5ghz channels since day one in sky q . It’s when it tries to change access points . From router to sky mini box . It can’t get the ip address in time so fails and gives you a 169 IP address. Nightmare seen another post on sky forum about it . Apparently sky and Apple spent a few weeks try8ng to fix someone’s phone only to recommend 2.4 channel as a fix. Pretty poor ! Not sure if you are with sky but from what I’ve read also affects some iPhone 8 as well
     
  8. poseidondt, Feb 19, 2018
    Last edited: Feb 19, 2018

    poseidondt thread starter macrumors newbie

    Joined:
    Feb 18, 2018
    #8
    Has anybody had the same issue like me ? where the Wifi turns off automatically at the on/off button but still shows connected ? (see my picture from beginning of the thread)
     
  9. anubis1980 macrumors 6502

    Joined:
    Oct 22, 2012
  10. Mlrollin91 macrumors G5

    Mlrollin91

    Joined:
    Nov 20, 2008
    Location:
    Ventura County
    #10
    You said you restored, did you restore as new or from a backup. if its from the backup, you are likely carrying over the corruption issue. Restore as new, then try it for a day.
     
  11. Chazzle macrumors 68000

    Chazzle

    Joined:
    Jul 17, 2015
    #11
    Restored from backup...
     
  12. poseidondt thread starter macrumors newbie

    Joined:
    Feb 18, 2018
    #12
    i restored from backup; yes, i will try now to restore as new and then see if it is hardware related or corruption from backup....
     
  13. MrTazz macrumors member

    MrTazz

    Joined:
    Sep 23, 2015
    #13
    My problem was to do with an app. Not sure which one as I’m still installing my apps back one by one to see which one keeps turning the WiFi off!!
     

Share This Page