Make a bootable USB for the first beta!

Discussion in 'macOS Mojave (10.14)' started by tywebb13, Jun 4, 2018.

  1. tywebb13 macrumors 68020

    Joined:
    Apr 21, 2012
    #1
    Here is how to make the bootable usb for the first developer beta:

    Format an 8 GB (or16GB) USB drive which should be called Untitled and formatted as Mac OS Extended (Journaled). The installer should be called Install macOS 10.14 Beta.app and should be in your Applications folder.

    Run this in Terminal:

    sudo /Applications/Install\ macOS\ 10.14\ Beta.app/Contents/Resources/createinstallmedia --volume /Volumes/Untitled
     
  2. GoodHealthIT macrumors member

    Joined:
    Nov 10, 2017
    Location:
    Adelaide
    #2
    Wondered what the change was. I ran it with the --applicationpath as well and although Terminal stated that command was deprecated, it still went ahead and created a bootable USB.
    Been at work all day so didn't have time to tinker with removing it, so thanks for saving me some effort...
     
  3. tywebb13 thread starter macrumors 68020

    Joined:
    Apr 21, 2012
    #3
    Actually this isn’t a mojave thing. The shortened command actually started with high sierra.
     
  4. Azkylinegtr macrumors newbie

    Joined:
    Sep 17, 2014
    #4
    I tried this on my APFS formatted MBP and got an error about APFS formatted drives not being able to be used for boot media. The USB I'm copying to is formatted to HFS+ I don't remember the exact error verbiage. I coped the installer to my 2011 MBP because I'm having issues on my imac. So I'm not sure if I'm just getting this error because the mac I'm trying to create the installer on isn't compatible with mojave (no metal GPU). Has anyone else on a APFS formatted drive been able to make a bootable usb for a clean install?
     
  5. jmantn macrumors 6502

    Joined:
    Mar 13, 2012
    Location:
    Tn
    #5
    I keep receiving the following:
    /Applications/Install macOS 10.14 Beta.app does not appear to be a valid OS installer application.

    I have two macs where 10.14 is already installed and another which is able to run 10.14 but currently on 10.13.5 and it keeps telling me beta.app isn't valid installer yet I can click through and install if I wish that way.
     
  6. mmomega, Jun 10, 2018
    Last edited: Jun 10, 2018

    mmomega macrumors demi-god

    mmomega

    Joined:
    Dec 30, 2009
    Location:
    DFW, TX
    #6
    Finally got home to have time to do a fresh install on my laptop. '16 MBP13

    Having issues at the moment creating the USB installer.
    1st attempt : used terminal script , everything seemed to go fine other than an error in terminal

    "Erasing disk: 0%... 10%... 20%... 30%... 100%

    Copying to disk: 0%... 10%... 20%... 30%... 100%

    xcrun: error: invalid active developer path (/Library/Developer/CommandLineTools), missing xcrun at: /Library/Developer/CommandLineTools/usr/bin/xcrun

    Making disk bootable...

    Copying boot files...

    Install media now available at "/Volumes/Install macOS 10.14 Beta"

    Terminal stated the media was created so I rebooted to install, chose to USB installer, got a minute or two in and received the circle/crossed out ghostbusters icon.
    Tried a second time after resetting PRAM, same issue.

    On 3rd attempt, this time I went to the developer page and downloaded Command Line Developer Tools for 10.14
    Installed all packages within the download.
    Recreated the install media.
    Now the icon on the desktop for the USB installer changed to the macOS icon when before installing dev tools the installer had the normal yellow external drive icon and the error within terminal is gone.

    About to restart and attempt a fresh install, I'll report back with progress in case anyone is coming across a similar issue.

    *** New attempt since xcrun error
    Same issue with the installer, circle crossed out icon.
    Now thinking my install drive may be the issue. Currently using a Samsung T3 256GB drive with a 10GB partition for the installer
    Now attempting a Sandisk Extreme Pro 128 3.0 USB via Hyperdock

    *** Different USB drive and fresh install went through as expected.
     
  7. shafez macrumors member

    shafez

    Joined:
    Jul 3, 2011
    Location:
    Egypt
  8. lemimouth macrumors regular

    Joined:
    Feb 14, 2015
    #8
    Thanks for the heads-up. I used the "old" command line and it worked perfectly, I didn't know about the shortened command
     

Share This Page