Make Messages private ?

Discussion in 'iPhone' started by Tig Bitties, Mar 5, 2015.

  1. Tig Bitties macrumors 68030

    Tig Bitties

    Joined:
    Sep 6, 2012
    #1
    I don't like how when I get an iMessage or any text, how it just pops up right in the middle of the screen. There's no privacy whatsoever.

    My Wife might text me saying bang me hard tonight. Or my Brother asking lets grab bag o weed tonight.

    Joking.

    But I don't like texts popping up like that. Is there way to change a privacy setting ? Or have them just show up in status bar only or something ?
     
  2. BigMcGuire macrumors demi-god

    BigMcGuire

    Joined:
    Jan 10, 2012
    Location:
    California
    #2
    Haha, had this same problem recently with a coworker who took my phone while my wife was texting me. He quickly handed it back. lol.

    Settings-->Notifications-->Messages --- turn off: Show on Lock Screen to turn it off completely on lock screen.

    OR scroll down a bit more and choose: Show Previews --- turn that off and it'll just say: Wife has sent you a message. (this is what I have off while Show on Lock Screen ON).

    Awesome username fyi.
     
  3. Tig Bitties thread starter macrumors 68030

    Tig Bitties

    Joined:
    Sep 6, 2012
    #3
    Thanks for the answer :)

    Wasn't an easy option to find.

    My user name, what can I say, that's what I like :D
     
  4. AAPLinc macrumors 65816

    Joined:
    Jul 27, 2012
    Location:
    Hollywood, CA
    #4
    Haha funny that you're just realizing this. Yes you can turn off previews, and banners even too, you can also turn message notifications off in lock screen and you can disable them from showing in the notification center.

    Here is how I have my texts set up:

    Show in notification center - No
    Badge App Icon - ON
    Show on lock screen - No
    Banners - None
    Show previews - No

    I simply just have the text sound and badge icon. I cant believe people just leave their phones with the texts showing to anyone who picks your phone up. I'm not hiding anything but it's just weird.
     

Share This Page