Make sure Port 3689 is Open Error when Syncing

Discussion in 'Apple TV and Home Theater' started by jwig53, Nov 23, 2010.

  1. jwig53 macrumors newbie

    Apr 22, 2009
    Michigan, USA
    I ran into this problem the other day and was able to resolve it and thought my experiences may help others as I could not find this solution when I searched on line for it. Hope it helps someone...
    I have several first generation Apple TV's (and one new 2nd gen black one) and they were working fine in my home network environment. I had a D-Link router and replaced it with a Airport Extreme Base Station. I kept the same Network name and security key. All my devices were able to pick back up and connect to the wireless without problem. The old ATV's required the network key to be re-entered but no big deal. That is until I went to play something. I could not access any content from my iTunes Library (getting the unauthorized to play file error). When I went to iTunes I was unable to sync the ATV getting the 3689 port message.
    I tried to reboot the ATV, the iMac, and even did a factory restore on the ATV with no luck.
    I have my iMac connected to the base station via Ethernet but also had AirPort enabled. I do not have the Firewall enabled and I do not have any third party firewall software installed on my iMac. I attempted adding iTunes and the port specified in the Firewall setting but still no luck.
    I finally disabled Airport to see if was a conflict between the Ethernet and Wireless and bingo! My Ethernet connection had an invalid IP. I set it back to DHCP and did a refresh. Applied the change, got a new IP with the correct scope instead of 192.168.x.x and everything connected.
    I don't if this will work for others but it worked like a charm for me.
    Hope it helps.
  2. newagemac macrumors 68020

    Mar 31, 2010
    It seems people with multiple Apple TVs especially a mix of old and new generations are having IP address problems. Often two devices would try to get the same IP address. You should go into Settings and give them different names (there are default room options or you can set custom names) and that should fix the problem.

Share This Page