making keyboard repeat rate extremely fast

Discussion in 'macOS' started by orchistro, Sep 26, 2008.

  1. orchistro macrumors newbie

    Joined:
    Sep 26, 2008
    Location:
    Seoul, Korea
    #1
    Hey guys!

    I'm wondering if there is any way to make my keyboard repeat rate extremely fast.
    I've already tried to adjust slide bars that appear on the keyboard/mouse section in the preference pane. But the maximum speed wasn't enough for me. It's only for people with great patience!

    So I tried to tweak system setting by using "defaults" command line utility.
    I found out that as I moved slide bars on preference window, InitialKeyRepeat and KeyRepeat values changed accordingly. (( KeyRepeat and InitialKeyRepeat keys are found wheh you type in "defaults read -g"))
    I decided to write a new value to those keys :

    $ defaults write 'Apple Global Domain' KeyRepeat 1

    But that didn't seem to have any effect.
    I thought that there must be something more. So I restarted the system.
    Unfortunately, after restarting the system, the autorepeat rate was even slower than before.
    It is frustrating to be unable to type in repeated characters in a speed of light!
    It really bugs me. Sometimes, I get angry because of it!

    Is there anyone that knows how to make the repeat rate even faster -- let's say, beyond the preference window's settings?

    Thankyou in advance :)

    I'm on OSX 10.5.5
     
  2. donga macrumors 6502a

    donga

    Joined:
    May 16, 2005
    Location:
    AZ
    #2
    why would you want the repeat rate so fast?

    the fastest setting already makes my eyes hurt :eek:
     
  3. spektrs macrumors newbie

    Joined:
    Feb 2, 2009
    #3
    i also wana to know how i can make it rate faster !!!
     
  4. lordthistle macrumors 6502

    Joined:
    Feb 29, 2008
    Location:
    Italy
    #4
    Then we understand why you don't want it faster (even if - may be - we aren't that interested in being acknowledge of that).

    thistle
     
  5. IvanQ macrumors newbie

    Joined:
    Aug 8, 2009
    #5
    solution

    It turns out that you have to specify the type of value (integer in this case), otherwise the number gets written as a string value and is ignored.

    defaults write "Apple Global Domain" KeyRepeat -int 0
     

Share This Page