Making MS-DOS(FAT 32) HDD "READ-ONLY"

Discussion in 'macOS' started by findpankaj, Jun 14, 2008.

  1. findpankaj macrumors member

    Joined:
    Nov 12, 2005
    #1
    I have 250 gigs HDD which I have partitioned into 2. One Extended(Journaled) and other as MS-DOS FAT32. My photos library is on FAT32 which I want to make READ-ONLY. This is because I want to manage photos with iPhoto but in no circumstances, let it screw my Library. Problem I am facing is, I am not able to make the permissions "READ-ONLY". I am the administrator and I could change permissions form my Mac partition. Why is that I am not able to change permissions on FAT32?

    I tried going to System Preferences and Sharing. I have included the mentioned drive in shared folders and users against them are READ-ONLY, only to find them READ-WRITE when I open this window again.

    What can be the issue.?
     
  2. CWallace macrumors 603

    CWallace

    Joined:
    Aug 17, 2007
    Location:
    Seattle, WA
    #2
    OS X does not appear to support editing permissions on FAT32 partitions. I can't change them on my Boot Camp partition. It might be possible via Unix commands from Terminal.

    Would it not have been easier to just leave the whole disc HFS+ and then set the permissions to read-only on your photo folder?

    If this was a separate drive, I'd recommend connecting it to a Windows machine and try setting the permissions there. VMWare Fusion offers a 30-day trial, so you could create a Windows VM and try and set the disk permissions on the FAT32 partition from the VM.
     
  3. Amdahl macrumors 65816

    Joined:
    Jul 28, 2004
    #3
    Command line

    From Terminal run "diskutil list"

    Spot your FAT32 drive, make note of the identifier column. In this example, I am using disk0s2

    "diskutil unmount disk0s2"
    "diskutil mount readOnly disk0s2"

    That should do what you want, repeat every time your reboot or reconnect the drive.
     
  4. findpankaj thread starter macrumors member

    Joined:
    Nov 12, 2005
    #4
    Error in mounting in readonly mode

    Well thanks for the suggestions. First of all, I have to have a FAT32 partition because I need to access that partition from windows machines.

    I tried the diskutil mount readonly <identifier>. I am getting this error
    "DiskManagement setuid-tool failure"
     
  5. chscag macrumors 68000

    Joined:
    Feb 17, 2008
    Location:
    Fort Worth, Texas
    #5
    As far as I know, you can't set read only permissions on a FAT-32 drive from either OS X or Windows without third party software. If it was formatted to NTFS, then yes.

    Regards.
     

Share This Page