Making progress sharing files and printers, but...

Discussion in 'macOS' started by Luis Ortega, Mar 13, 2008.

  1. Luis Ortega macrumors 6502a

    Joined:
    May 10, 2007
    Location:
    Fetcham Surrey UK
    #1
    I have been trying for over a week to get my new mac pro and my son's PC to share files and printers with no luck.

    (We use a Belkin pre-n wireless router. The Mac is connected via ethernet cable and has a USB Canon printer connected to it. The PC connects via a Belkin USB wireless n adapter and has USB Epson printer connected to it. The PC runs Windows XP and the Mac Pro runs Leopard 10.5.2 and also has Windows XP on it via Bootcamp.)

    I had no trouble getting printer and file sharing going between the two computers when both are running Windows, but I could get nothing to work when the Mac Pro was running OSX.
    I tried everything that people on the forums and the Apple support documents advised but with no success. Repeatedly.

    Then yesterday I suddenly discovered that my son's PC was listed under shared in Finder.
    I tried printing from his computer to the printer on my Mac and it worked.
    I could now see his shared folders on my Mac.
    Almost there!

    Then when I tried to print from my Mac to the printer on his PC it started printing- but not the test document I had sent.
    It started printing out pages and pages of lines of text and characters.
    I let it run for a while but it never stopped and I was afraid that it would run out of ink so I turned off the printer to stop the printout.
    I could not stop it from the printer window on my Mac because it said the job was complete.
    When I restarted the printer it stayed idle, but when I tried to print my test page again the process started all over until I stopped it again by turning off the printer.
    The first few lines look like this:

    %!PS-Adobe-3.0
    %APL_DSC_Encoding: UTF8
    %APLProducer: (Version 10.5.2 (Build 9C31) Quartz PS Context)
    %%Title: (untitled)
    %%Creator: (TextEdit: cgpdftops CUPS filter)

    and so on. It was up to 5 pages of this when I stopped it.

    The second time I tried, it started again printing the exact same stuff until I stopped it.

    Do I need to let it print its little heart out until it gets it out of its system, or is this an error?

    Can anyone please advise on what is going on and what I can do now to get the final piece of my printer and file sharing setup to work?

    Thanks a lot for any advice.
     
  2. MisterMe macrumors G4

    MisterMe

    Joined:
    Jul 17, 2002
    Location:
    USA
    #2
    There is your answer. Your question has been asked and answered on this forum too many times to count. To print from a Mac to a networked printer, you need to use a CUPS driver. Most likely, one has been developed for your specific model. Search this forum for other references to CUPS, Gutenprint, and LinuxPrinting. You should find a link to the driver you need.
     
  3. Luis Ortega thread starter macrumors 6502a

    Joined:
    May 10, 2007
    Location:
    Fetcham Surrey UK
    #3
    Thanks for the clue.
    Would that CUPS driver need to be installed in the Mac so that it could print from the printer attached to the PC or does it get installed in the PC as a second driver for the printer that the Mac could access when it's sending a print job to it?
     
  4. Luis Ortega thread starter macrumors 6502a

    Joined:
    May 10, 2007
    Location:
    Fetcham Surrey UK
    #4
    Thanks MisterMe.
    I installed the latest gutenprint drivers for the shared printer and it now works.
    I finally got my Mac/PC printer and file sharing setup complete and working properly. Now the network all works whether we are using two PCs (PC and Mac running Win xp) or PC and Mac running Leopard.
    I just wish I knew what I did right, since I have tried so many different things that I just don't know.
    Now I'm going to try to get my MBP added to the network and also be able to share files and printers.
     

Share This Page