Many app updates fail - need iOS4!

hsotnicam8002

macrumors 6502
Original poster
Mar 13, 2008
415
73
United Kingdom
After downloading updates to many apps (almost one every other day or so) iTunes will not allow the iPad to update them stating that the OS is not the required recent version. What a waste of time and why are we still waiting for an update as it feels like I've had my iPad for ever! Just like the iPhone had to wait for years for updates to give it functions that most phones have had since Adam, it seems to me that we are being short changed by Apple. This will be especially true if the rumours are true of having to pay for iOS4 on the iPad! Apple, should pull its finger out and stop moving from one project to another before leaving the first in a satisfactory state! Or is a name change coming - Applesoft?!
 

sparkie1984

macrumors 68020
Dec 20, 2009
2,218
849
a small village near London
Presumably your on about iPhone native apps? As all my iPad apps work fine updating!

Can't really blame apple to much as the iPad software is a bit different to the iPhone.

But I agree that it would be nice to see the new ios on ipad
 

xraydoc

macrumors demi-god
Oct 9, 2005
7,452
1,662
192.168.1.1
There will be NO charge to upgrade current iPads to iOS 4. iOS 5, maybe, but not 4.
Apple has gone on record to say the update to iOS 4 will be free of charge.
 

blackNBUK

macrumors 6502a
Feb 19, 2010
569
0
UK
I think that part of the blame has to be shared by the App developers too. It is possible to build an App that uses iOS4 features but is still compatible with iOS3. For example Flickr has recently added multitasking support but still appears to work on my iPad.
 

Night Spring

macrumors G5
Jul 17, 2008
13,073
5,102
I think that part of the blame has to be shared by the App developers too. It is possible to build an App that uses iOS4 features but is still compatible with iOS3. For example Flickr has recently added multitasking support but still appears to work on my iPad.
Yup. You need to complain to the app developers if an app doesn't work on 3.x. It's the developers who decide what OS an app works on, not Apple.
 

WLS

macrumors 65816
Jul 10, 2008
1,231
62
Yea I've got an app "drinks and cocktails" that gives me the same message for that app on my iPad..
I would expect the App developer to have fixed it by now but no so I'm going to have to delete it. :(
 

ssdeg7

macrumors 6502a
Jul 15, 2010
749
2
Release it now!

I'm really getting pissed out by having to wait for this update, this is stuff that should have been released since the launch date of the iPad, come on, multitasking? That's no new thing!

I don't know if it is Skypes fault but the Skype app now works somehow buggy at my iPad since the last update, the same for IM+

I really hope the iOS 4.0 for iPad comes with much more stuff than for the iPhone, it must be worth the wait.