Many emails just show "Loading..." and never load

Discussion in 'macOS' started by altjx, Aug 17, 2013.

  1. altjx macrumors member

    Joined:
    May 12, 2010
    #1
    Just got the new Macbook Pro Retina and trying to set up an Exchange account -- the same one I have set up on my iPhone 5.

    However, on the Macbook Pro, I can open up the Mail app and see some of the messages in the left column (showing the From name, subject, and first line of the message). But when I click on the actual email, it just shows "Loading..." in the right section where the message is supposed to show.

    It's so weird, because some of the messages show, and then there's some other ones that just shows "Loading..."

    I've tried a few things such as running updates, rebooting, re-adding the Exchange account, etc. I can't get this issue fixed... Can someone please help?
     
  2. sofianito macrumors 65816

    sofianito

    Joined:
    Jan 14, 2011
    Location:
    Spain
    #2
    I had a similar issue in the past. Have you tried rebuilding the mailboxes? It might work...
     
  3. altjx thread starter macrumors member

    Joined:
    May 12, 2010
    #3
    Hmm, I haven't tried doing this yet. Is there a simple way to do this? (No worries, I'm Googling as we speak but having difficulty finding specific instructions for Mountain Lion.) This article (http://support.apple.com/kb/PH11811) just says select a mailbox, but doesn't say anything about how to get to the mailbox to select it in the first place.

    ----------

    And... after finally figuring out how to get to the mailbox, the Rebuild button is greyed out. Any thoughts?

    EDIT: Nevermind, it looks like it's rebuilding... According to the Apple article, my mailbox will appear empty until the download is complete. This is weird because this email is only 3-4 days old... I don't know why it would take more than 2-3 minutes to re-download all of its mail.
     

Share This Page