Become a MacRumors Supporter for $50/year with no ads, ability to filter front page stories, and private forums.

Diskutant

macrumors 6502
Original poster
Jun 1, 2019
414
417
I'm using iTunes match (and currently also have an Apple Music subscription) and want to play random songs. But many songs only play the first 14 seconds and then after a few seconds of nothing it starts to play the next song.
When I try to download one of those troubled songs I get a message telling me to check my internet connection and "err = 7507"
On iOS the same songs download just fine.

Any ideas what could cause this?

m1 MacBook Air
macOS Monterey 12.3
Music Version 1.2.3.56
 

dadudeness

macrumors regular
Oct 31, 2007
115
11
de
No solution, but it wasn't fixed in macOS 12.3.1. At this point the current macOS Music app seems like a way hotter mess than iTunes ever was
 

nthev

macrumors newbie
Aug 14, 2008
2
0
I've had the same issue and got onto apple support. Having been escalated the person I spoke to told me that the Engineers haven't received any reports of this issue (hard to believe given there are a number of people reporting this around the web) but that he has now escalated it to them and I should hear what's happening within 5 days. However, there is a workaround. Turn off Lossless Audio in the Music App Playback Settings. Then Quit music and after relaunch it playback continues beyond 14 seconds all the way to the end!
 

Diskutant

macrumors 6502
Original poster
Jun 1, 2019
414
417
@nthev did you ever hear back from them?

The last months I was on my desktop mac, so just playing the local files, but right now I'm on the MBA and I get this 14 seconds bug again. Lossless Audio was already turned off. So for me that doesn't fix it. :'(
 

pewtey

macrumors newbie
Sep 29, 2022
1
0
Same exact issue here. I've had this issue for months and it's driving me crazy. Used to only happen when playing songs from my Mac to my HomePod. Now it's happening also with my AirPods Pro. Zero issues with my iPhone. Zero issues with playback on my mac's internal speakers. Sometimes I am able to download the song, after which it will play just fine. Other times it will not download and gives me the error message.

Only link I've seemed to find is the songs are almost always "matched" via iTunes Match. Never happens with Apple Music tracks or "uploaded" tracks. Maybe there's something in the iTunes Match algorithm that is causing havoc?

Lossless is off. Dolby Atmos is also off (which I'd read might be a contributing factor). Not sure what else to do. Very, very maddening situation.
 
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.