Many Java Sites Not working All browsers

Discussion in 'OS X Mountain Lion (10.8)' started by Helipil0t, Mar 10, 2013.

  1. Helipil0t macrumors newbie

    Mar 10, 2013
    I've been pulling my hair out trying to get to the bottom of this problem. I've noticed many online store "purchase" buttons or "shopping cart" buttons are dead and don't work. Other sites that have java based video players don't work. This applies to all browsers. Safari, Firefox, Chrome, Opera.... etc..

    Here are some examples:
    I wanted to look at some watches. I get directed to the country-gate page where I should be able to select my country. Except the button is blank.
    Any "add to cart" button does nothing.

    Using parallels all the above examples work just fine under windows XP using an assortment of browsers.

    I have the latest Apple Java update installed and also have the latest Browser plugin from Oracle. I've tried removing java completely and re-installing to no avail. I've been googleing the hell of this problem and can't find any solutions. It seems to be affecting more and more websites.

    Could anyone please shed some light on this issue for me. I would appreciate it. Cheers!

    Running OSX Mountain Lion 10.8.2

    java version "1.6.0_43"
    Java(TM) SE Runtime Environment (build 1.6.0_43-b01-447-11M4203)
    Java HotSpot(TM) 64-Bit Server VM (build 20.14-b01-447, mixed mode)

    Oracle Java Version 7 Update 17
  2. chown33 macrumors 604

    Aug 9, 2009
    Sailing beyond the sunset
    I have Java disabled in Safari. However JavaScript is enabled.

    When I visit this page:

    I see a drop-down menu, that does an animated expand when I click it.

    I also tried the "Add to Cart" button at speedcubeshop, and it worked, using the identical Safari configuration: Java disabled, JavaScript enabled.

    In Safari, choose Safari menu > Preferences item, then click the Security pane.

    You should see two separate checkboxes, one for Java, another for JavaScript. Make sure JavaScript is enabled.

    If you want Java enabled, then make sure its checkbox is checked.

    There should be similar settings in any browser (Java vs. JavaScript).

    I have never been to any website where the shopping cart required Java. JavaScript, yes. Java, no.

    Java and JavaScript are completely different things. The analogy I heard is "Java is to JavaScript as ham is to hamster." That is, they begin with the same letters, but are functionally unrelated.
  3. Helipil0t thread starter macrumors newbie

    Mar 10, 2013
    I just tried what you suggested in safari and I still have the same issue. I restarted the browser figuring it might help but it's still not providing me with a drop down menu. I'll try with the other browsers and see what happens.

    Would you have any other ideas?
  4. Helipil0t thread starter macrumors newbie

    Mar 10, 2013
    Yeah this definitely doesn't work for me. I have tried disabling Java via Safari as well in the Firefox Plugins pane. I've also went through OSX's Settings > Java and have disabled it from there. I'm still getting the same issue. :(
  5. wrldwzrd89 macrumors G5


    Jun 6, 2003
    Solon, OH
    As chown33 said further up, check your JavaScript settings. This is NOT the same thing as Java.
  6. Helipil0t thread starter macrumors newbie

    Mar 10, 2013
    Yes I did check to make sure JavaScript is in fact enabled. Same deal.
  7. Helipil0t thread starter macrumors newbie

    Mar 10, 2013
    Can anyone else offer me any help? Enabling JavaScript in any browser is not solving the issue. It seems to be system wide. Currently Chrome, Firefox and Safari are affected. As stated above, Chrome and Firefox both work properly via a Windows XP Parallels instance.

    Thanks again for any help!
  8. jameslmoser macrumors 6502


    Sep 18, 2011
    Las Vegas, NV
    Did you open the Java Control Panel from System Preferences, then under Security check to make sure that the box for "Enable Java content in the browser" is checked?
  9. Helipil0t thread starter macrumors newbie

    Mar 10, 2013
    Yes I have done it via the Java consol under Settings as well. Intersting note. I'm not convinced that it's a JavaScript problem.

    The following link uses Java:

    You're supposed to see a bunch of Rubik's cubes under Case and Mirror. Which I can't.
  10. Helipil0t, Mar 15, 2013
    Last edited: Mar 15, 2013

    Helipil0t thread starter macrumors newbie

    Mar 10, 2013
    Ok so I got the site working by disabling Java 7 and re-enable Apple's old Java 6 runtime using the following instructions.

    With it running works fine. But the other above mentioned websites still aren't working properly. Case in point, the citizen watch site is still not displaying a drop down menu for countries.

Share This Page