Many Problems with my Penryn MBP!

Discussion in 'MacBook Pro' started by Kaeonadai, Jun 8, 2008.

  1. Kaeonadai macrumors newbie

    Joined:
    Feb 27, 2008
    #1
    Hello. I have a laundry list of problems with my 17" MacBook Pro, purchased back when the penryn first came out.

    The computer won't boot. I don't hear a startup chime, and I hear the fans starting and the disc drive starting, but the display doesn't start. The sleep light turns on, though. When I try turning it off and starting in safe mode, resetting the PRAM, starting in hardware test mode, or even starting from the DVD (both option and C methods), it does the same thing. I think the keyboard doesn't work. I've tried resetting the PMU and the PRAM (I don't think it accepted the PRAM reset).

    Does anyone know of any fixes, or possible causes? I read about the 1.5 efi firmware update causing this, and I think I *might* have applied this. I can't remember, though!
     
  2. jjahshik32 macrumors 603

    Joined:
    Sep 4, 2006
    #2
    Firmware 1.5?? That's a bunch of problems...
     
  3. Kaeonadai thread starter macrumors newbie

    Joined:
    Feb 27, 2008
    #3
    You think it could be 1.5? I'm not even sure I installed it.
     
  4. alphaod macrumors Core

    alphaod

    Joined:
    Feb 9, 2008
    Location:
    NYC
    #4
    When was there a EFI update? Either I know I've applied every update so far, so either it doesn't exist, or it didn't cause any issues for me.
     
  5. Kaeonadai thread starter macrumors newbie

    Joined:
    Feb 27, 2008
    #5
    I took it to the genius bar today, and they're replacing the logic board. Free repair. They also swapped out my iPhone (it wasn't recognizing my SIM card occasionally).

    Got to love apple support.
     

Share This Page