Mapping location & Compass is 300 miles off

Discussion in 'iPhone' started by AK10R, Sep 12, 2010.

  1. AK10R macrumors regular

    Joined:
    Jun 20, 2009
    Location:
    Fairbanks, Alaska
    #1
    I have an iPhone 4 with 4.02. When I open maps the locator put me in a town about 300 miles away. The phone does this at my home or different location around town where I live. It locates me to the same spot in a river 300 miles from my home regardless of my current location.

    At the grocery store yesterday the maps put me in the current and correct location. I went into the parking lot and I was back in the river 300 miles away from where I was. Last night at my home the maps put me in the correct location. This morning I’m back in the river 300 miles away.

    The compass app also puts me in the river 300 miles away. I tried my wife iPhone 4, it put her in the river 300 miles away. I have tried maps using both my wifi and 3G and have the same results.

    I called Apple and they had me do the standard restart things and on/off different “Location Services” it did not work. Apple wants me to restore the phone which I will do (and upgrade to 4.1) but I’m not sure if it will help.

    Any thoughts?
     
  2. Revelation78 macrumors 68000

    Revelation78

    Joined:
    Dec 18, 2008
    Location:
    North Carolina
    #2
    Restore as a new iPhone.
     
  3. kdarling macrumors demi-god

    kdarling

    Joined:
    Jun 9, 2007
    Location:
    First university coding class = 46 years ago
    #3
    Both iPhones do this?

    Do you have GPS turned on? Do you get a tiny pulsating dot, or a large circle?

    If you're not using GPS, and it's using cell id locating instead, then this can happen if the carrier swaps cell ids around. (Something like this happened last year and for a few weeks made everyone around some spot in California think they were in Colorado.)

    Try the restore first. Then if it still happens, log a case with ATT... again, only if you're NOT using GPS.
     
  4. AK10R thread starter macrumors regular

    Joined:
    Jun 20, 2009
    Location:
    Fairbanks, Alaska
    #4
    Have location services turned on….. I get the blue stick pin and a pulsating large circle around the pin.

    Google earth is also pinpointing my location 300 miles away.

    I will try the restore as new phone and update to 4.1 later today……
     
  5. androiphone macrumors 65816

    Joined:
    Dec 13, 2009
    #5
    next time you get a correct lock on leave the maps open and drive home and see what happens, could track you correctly back home or at some point it will switch to 300 miles away.

    because you say it is happening to both phones the only think I can think off is that there is a GPS jammer in the area of your home, I guess you could ask a neighbor or friend with a GPS device to try their device at your house.
     
  6. UCLAKoolman macrumors 6502a

    Joined:
    Jun 21, 2010
    #6
    Are you sure you're not using a galaxy s phone?!?
     
  7. AK10R thread starter macrumors regular

    Joined:
    Jun 20, 2009
    Location:
    Fairbanks, Alaska
    #7
    Or.... I really am in a river 300 miles from where I think I am :eek:
     
  8. cirial macrumors regular

    Joined:
    May 2, 2010
    Location:
    Pompano Beach, FL
    #8
    If this happens on both your phone AND your wifes, then I would suspect that its something with the cell towers/gps in your area. Call AT&T and explain to them it happens on more than one phone. Know anyone else that you can ask in your immediate area that you can ask if it happens to them?
     
  9. PNutts macrumors 601

    PNutts

    Joined:
    Jul 24, 2008
    Location:
    Pacific Northwest, US
    #9
    LOL
     
  10. AK10R thread starter macrumors regular

    Joined:
    Jun 20, 2009
    Location:
    Fairbanks, Alaska
    #10
    I just went to the store again and it worked as designed. The maps tracked us along our route. Now I’m back home and the maps are again showing me 300 miles away in a river.

    I think this is a sign. I may drive 300 miles to that spot in the river… I bet there is a UFO in the water there……

    I’ll give ATT a call tomorrow…….
     
  11. AK10R thread starter macrumors regular

    Joined:
    Jun 20, 2009
    Location:
    Fairbanks, Alaska
    #12
    ifrogz.... it does it with and without the case.
     
  12. Revelation78 macrumors 68000

    Revelation78

    Joined:
    Dec 18, 2008
    Location:
    North Carolina
    #13
    Are there any WiFi routers nearby broadcasting? If there are any, try disabling WiFi on your iPhone and see if the problem persists.
     

Share This Page