Maps in Mavericks don't show anything

Discussion in 'OS X Mavericks (10.9)' started by RamonPouw, Oct 23, 2013.

  1. RamonPouw macrumors newbie

    Joined:
    May 30, 2008
    #1
    Dear forum users,


    Yesterday I installed Mavericks on my Macbook 2009...

    But there is still an issue, MAPS is not showing anything... When I am opening MAPS on my Macbook, there is a blank page.. can't see any streets or something..

    Someone familiar with this problem?

    Thanks in advance.

    Ramon
     
  2. RolyPolyBird macrumors regular

    Joined:
    Aug 13, 2010
    #2
    Given the quality of Apple Maps you should consider yourself blessed.
     
  3. jonasdamn macrumors 6502a

    Joined:
    Mar 4, 2013
    #3
    same here if viewing via standart mode
     
  4. activate macrumors regular

    Joined:
    Dec 24, 2011
    #4
    Yeah, I've noticed that in dev previews. Go to fullscreen.
     
  5. jonasdamn macrumors 6502a

    Joined:
    Mar 4, 2013
    #5
    for me it didnt help :/
     
  6. hallux macrumors 68020

    hallux

    Joined:
    Apr 25, 2012
    #6
    I saw the same thing the first time I opened Maps. I have since rebooted at least once and re-opened after the reboot and it's working now. I kind of wish the 2-finger swipe gesture (up/down) was for zoom and not for scrolling.
     
  7. jonasdamn macrumors 6502a

    Joined:
    Mar 4, 2013
    #7
    for me it is like that:
    no issues via hybrid mode, only via standart
    Tried rebooting, full screen, nothing helped
     

    Attached Files:

  8. activate macrumors regular

    Joined:
    Dec 24, 2011
    #8
    Try to access it through calendar, iphoto or contacts. Sometimes that can break the cycle.
     
  9. jonasdamn macrumors 6502a

    Joined:
    Mar 4, 2013
    #9
    Didnt help also, damn sucks :/
     

    Attached Files:

  10. ABC5S macrumors 68040

    Joined:
    Sep 10, 2013
    Location:
    Florida
    #10
    Just checked mine and everly thing seems to be working. Tried different locations as well. Unknown why mine works and yours do not. Good luck
     
  11. activate macrumors regular

    Joined:
    Dec 24, 2011
    #11
    Access the downloaded installer and in the packages folder, you'll find the maps package. Reinstall just the maps package. You will have to redownload mavericks if you didn't keep it.
     
  12. jonasdamn macrumors 6502a

    Joined:
    Mar 4, 2013
    #12
    Friend have mac pro, macbook and this issue appeared on mac pro only. Strange bug
     
  13. Mr. McMac Suspended

    Mr. McMac

    Joined:
    Dec 21, 2009
    Location:
    Far away from liberals
    #13
    Mine works ok
     

    Attached Files:

  14. jonasdamn macrumors 6502a

    Joined:
    Mar 4, 2013
    #14
    thanks, however i press download at App store and no reaction, doesnt start downloading. I dont know if i have kept it. This morning i have downloaded and installed mavericks, didnt make anything more
     
  15. oMc macrumors 6502

    oMc

    Joined:
    Oct 17, 2010
    Location:
    Finland & France
    #15
    Same here. I don't even have a grid in standard view. Blank map with just the blue point of the location. The map is here when I open the app and then disappear.

    Works quite fine in other views (hybrid or satellite, but also sometimes disappear) and works perfectly in fullscreen mode.

    The in-app map of Aperture is also always disappearing.

    Strange.
     
  16. jonasdamn macrumors 6502a

    Joined:
    Mar 4, 2013
    #16
    Clean install fixed my issues
     
  17. oMc macrumors 6502

    oMc

    Joined:
    Oct 17, 2010
    Location:
    Finland & France
    #17
    This is a little bit extreme.

    I think I am going to wait until 10.9.1 before thinking about a clean install. OS X Maps is not an essential feature for me.
     
  18. shootzkden macrumors newbie

    shootzkden

    Joined:
    Sep 12, 2013
    #18
    Maps didnt work for me also, I read somewhere about having to re-enable certain fonts to get maps to load. After re-enabling all my fonts, maps began working.
     
  19. exonico macrumors newbie

    Joined:
    Oct 18, 2013
    #19
    Hello,

    I've got the same bug, works fine in full screen mode but not in standard one.
    Question though, how do you update those fonts ?
    Many thanks
     
  20. irnchriz macrumors 65816

    irnchriz

    Joined:
    May 2, 2005
    Location:
    Scotland
    #20
    I had this issue on my iMac. I created a new profile and it worked fine in that so rather than fresh install I just shifted everything to the new profile. No idea what was messing it up though.
     
  21. ABC5S macrumors 68040

    Joined:
    Sep 10, 2013
    Location:
    Florida
    #21
    Update method, and now Fresh Clean Install, and no issues with Map each time. Why many with no issues, and some with them ? Interesting. :)
     
  22. oMc macrumors 6502

    oMc

    Joined:
    Oct 17, 2010
    Location:
    Finland & France
    #22
    How do you re-enable your fonts?
     
  23. oMc macrumors 6502

    oMc

    Joined:
    Oct 17, 2010
    Location:
    Finland & France
    #23
    OK, you can restore the fonts using the Font Book of Mac OSX.

    I seems it fixed my problem in Maps, the map is always showing now. Issue fixed with the map of Aperture, too, btw :)
     
  24. 844957 Suspended

    Joined:
    Sep 16, 2013
    #24
    this happens to me sometimes

    go to terminal
    killall Dock

    Maps works after i do this.
     

Share This Page