Maps only showing grid; no actual map.

Discussion in 'OS X Mavericks (10.9)' started by kryptonkid07, Oct 23, 2013.

  1. kryptonkid07 macrumors regular

    kryptonkid07

    Joined:
    Jul 14, 2010
    Location:
    Houston, TX
    #1
    I have an early 2009 model iMac that still runs fantastically. I haven't had any issues thus far.

    With Mavericks, everything is just as speedy and I haven't encountered any major problems, except for one: Maps doesn't work for me.

    I can't view Maps at all. The application is open and it even finds addresses and my current location, but I don't actually see the map. All I see is the grid behind the map.

    Anyone else having this problem? :(
     

    Attached Files:

  2. dinesy macrumors newbie

    Joined:
    Oct 31, 2011
    #2
    me too

    same problem.

    It was working...last week in fact. But just opened it today and its like your pic.
     
  3. ufkdo macrumors 6502

    Joined:
    Oct 30, 2010
    Location:
    Turkey
    #3
    Does it work on hybrid mode, or on satellite mode? A few people also reported this problem and, as far as I remember, some of them were able to use it in hybrid mode.
     
  4. DisneySMAX, Nov 27, 2013
    Last edited: Nov 28, 2013

    DisneySMAX macrumors member

    Joined:
    Jan 6, 2010
    #4
    It is a strange language/region bug. I had the same problem. Close Maps then go to...

    SYSTEM PREFERENCES > LANGUAGE & REGION > Change region to something else Like UK if you are in the US or US if you are in the UK and open maps again. The maps will appear. Then just change it back in System preferences to what it was before.
     
  5. shootzkden macrumors newbie

    shootzkden

    Joined:
    Sep 12, 2013
    #5
    Had the same problem also, enabling some fonts that i had disabled and/or deleted fixed it for me.
     

Share This Page