Maps showing grid only

Discussion in 'Apple Watch Apps' started by garethjs, Dec 27, 2016.

  1. garethjs macrumors 6502a

    Joined:
    Nov 11, 2008
    #1
    my Apple Watch maps app is only showing a grid despite pinpointing me correctly

    Is anyone else having this issue?

    Open maps on watch, select my location...
     
  2. chuyn macrumors 6502

    Joined:
    Nov 13, 2015
    #2
    This happens to me too. Series 0. I can leave it for however long and it won't show anything other than the grid.

    Odd thing is it shows the map properly when I search locations or POI's though. Just not when I tap on "my location" first. If I search directions so it shows a destination (and the map is displayed), then I tap on the arrow to show my location, it'll then show the map properly. And will then work if I back out and tap on the "my location" option.
     
  3. sassenach74 macrumors 65816

    sassenach74

    Joined:
    May 3, 2008
    Location:
    Hampshire, England
    #3
    Same for me (unless I zoom out loads) S0 SS 3.1.1
     
  4. cfc macrumors regular

    Joined:
    May 27, 2011
    #4
    I had this once and had to unpair and re-pair the watch to fix it, which was a bit of a pain because it takes a while.

    However, if you haven't already, then it is worth rebooting both the watch and the phone first, in case that fixes it for you.
     
  5. garethjs thread starter macrumors 6502a

    Joined:
    Nov 11, 2008
    #5
    Im suppose to unpair the watch and re-pair each and every time?!?
     
  6. cfc macrumors regular

    Joined:
    May 27, 2011
    #6
    Hopefully it won't happen again. I am a developer of a maps app for the watch, so I use maps on it a lot and I have only ever seen it once. It seems to get into some state where the map just won't appear. I tried rebooting both the phone and the watch but to no avail, so I eventually re-paired it and that fixed it.

    I wish I could say that it will definitely fix the problem and that it probably won't happen again, but I can't. All I can say is that I use it a lot and it's only happened once for me, and that re-pairing it fixed it. Hope that helps.
     
  7. garethjs thread starter macrumors 6502a

    Joined:
    Nov 11, 2008
    #7
    It's happening on my fiancée phone as well. I don't care much about the maps app on the watch anyway. But it's affecting the Uber maps app too.
     
  8. Integral Calculus macrumors newbie

    Integral Calculus

    Joined:
    Apr 13, 2017
    #8
    --- Post Merged, Apr 13, 2017 ---
    I've had my Apple Watch 2 weeks and the map worked for the first week. Since then I only get the grid. I've unpaired, repaired, rebooted and only the grid appears. Actually getting tired of Apple's crappy products, inferior packaging and lack of service and responses
     

Share This Page