MAS says no updates?

Discussion in 'OS X Mountain Lion (10.8)' started by 76ShovelHead, Apr 22, 2013.

  1. 76ShovelHead macrumors 6502a


    May 30, 2010
    Okay, I'm starting to get ticked off with OS X...

    I haven't updated to iTunes 11, or updated iPhoto...

    So when I open either apps, and plenty others, they say "Update Available." I decided to update iPhoto but then it opens the app store where it says no updates available. So I tried iTunes which I KNOW has an update available and it did the same.

    It even says I haven't purchased iLife or OS X ML.

    I've done permission fixes, and do them regularly, and check the startup volume, everything's "good."

    I tried manually installing the iPhoto update, downloading it from the Apple website, and even that failed...

    Uggghhhh! Anyone have any ideas of what's going on?!
  2. FotoDirk macrumors member

    Apr 5, 2010
    You don't need to open the application for the updates.
    You must open the app-store or use menu: apple-> software update

    If the updates are not showing then make a refresh in the app-store application (cmd+R).

Share This Page