Massive flaw in iMessage

Discussion in 'iOS 5 and earlier' started by TheOne888, Oct 27, 2011.

  1. TheOne888 macrumors newbie

    Joined:
    Jul 1, 2010
    #1
    Hi all,

    I know some people have been comparing iMessage to other IM apps however, as convenient as it is using iMessage, I've unfortunately found a massive flaw which will stop me from using it until it's fixed (if it will be fixed!!).

    I've discovered that when using emoticons, it is classed as a picture message. This is fine when your iMessage is delivered properly however, if it is sent as a text (this has been happening a lot lately!! :mad:) it will charge you the cost of a picture message!!

    So although I have an unlimited SMS plan, this unfortunately does not cover MMS's.

    I'm in the UK on the o2 network, anyone else also notice this?
     
  2. verwon macrumors 68030

    verwon

    Joined:
    Jul 26, 2011
    Location:
    Seattle
    #2
    It's not iMessage making it an MMS, that's your carrier, since it's being sent that way, same as if you put a picture in a regular text message. Apple can't change your carriers rules and practices.

    If you don't want it to send that way, then turn off the default option to send it as a text.
     
  3. Stealthipad macrumors 68040

    Stealthipad

    Joined:
    Apr 30, 2010
    #3
    +1

    No odubt you need to be aiming your anger at your carrier!:(
     
  4. zman98 macrumors member

    Joined:
    Jun 21, 2010
    #4
    I thought iMessage bypasses the carrier's SMS system and sends it via data usage.
     
  5. verwon macrumors 68030

    verwon

    Joined:
    Jul 26, 2011
    Location:
    Seattle
    #5
    If it fails to send as iMessage, it reverts to using text.

    That's exactly what he said happened, iMessage sending failed, so it was sent through text, which made it an mms.
     
  6. braindead5400 macrumors regular

    Joined:
    Jul 25, 2010
    Location:
    Wisconsin
    #6
    However he also stated that in general it sends a lot of messages as texts and not imessages (happens to me very often). If he turns off the "send as sms" option then doesn't that mean his imessages, when they fail (and they fail often) just won't go out at all? That'll help with picture messages but it will be a huge hassle with text messages.
     
  7. jdbr macrumors member

    Joined:
    Oct 7, 2010
    Location:
    Northern Ireland, UK
    #7
    Turn off mms

    You can turn off MMS without turning off SMS. I'm on O2 as well and I have never sent MMSs since they changed the rules and started charging from them. iMessage is brilliant because now I can send those pictures etc without a charge. To protect myself from O2 charges I turned off MMS. It won't send a picture picture if the recipient isn't able to take an iMessage for some reason. However I keep SMS on so that iMessages can convert to texts when the recipient is in the above situation.
     
  8. MonkeySee.... macrumors 68040

    MonkeySee....

    Joined:
    Sep 24, 2010
    Location:
    UK
    #8
    I've sent a few messages (including pictures) to my bro in oz and when i'm typing it says "iMessage" but it then mugs me off and sends it as a normal text.

    If i turn off "send as SMS" will it give me an alert or just not send?
     
  9. rwwest7 macrumors regular

    Joined:
    Sep 24, 2011
    #9
    You have to send to an email and not a phone number, I think.
     
  10. srcstc macrumors member

    Joined:
    Oct 22, 2010
    #10

    Or don't send emoticons. Problem solved!!
     
  11. brendanryder macrumors 6502a

    brendanryder

    Joined:
    Dec 28, 2006
    Location:
    Calgary
    #11
    Exactly, just use some smiles :)
     
  12. YoYoCome macrumors newbie

    Joined:
    Apr 17, 2010
    #12
    If you turn OFF your "Send As SMS" option, iMessage will let you know if you've sent the message successfully by showing you "Delivered" below the message bubble. However, if the receiving party does not have the "Send Read Receipts" turned ON, you will never know if the receiving party got the message or not until he/she replies your message.

    Turning off the "Send As SMS" is definitely the route I am going through. This way it can distinguish clearly between the people in my contacts using iMessage or Text Messages. (I send messages to friends in different countries, I don't want to incur any international text charges when there's a problem with data/wifi.)
     
  13. Greenstick macrumors newbie

    Joined:
    Mar 14, 2009
    Location:
    UK
    #13
    Surely you should be asking why iMessage failed in the first place. The carrier sms/mms hasn't failed, thats just doing what it should do.

    This is an Apple issue.
     
  14. YoYoCome macrumors newbie

    Joined:
    Apr 17, 2010
    #14
    Well, what if iMessage failed due to loss of reception? Then isn't that the carrier's issue? Or is that the user's issue for going into a dead zone? LOL! Is it really that important to see whose issue it is?

    I think its more important to let people know the importance of turning off "Send As SMS" so users won't incur extra charges.

    If "Send As SMS" is turned OFF, iMessage will queue your messages until the receiver has data again.
     
  15. urkel macrumors 68030

    Joined:
    Nov 3, 2008
    #15
    Its gross how people instantly wave off any fault to Apple over everything.

    The OP has a legitimate issue that can end up being costly for those who make assumptions on how iMessage works based on Apple's own advertisements. iMessage is seen by many to be a low/no-cost alternative to texting which means that people may be expecting to send a "free" iMessage and then somehow incur a charge because it shifted to become a text/mms with no warning. Imagine if you're texting internationally with no SMS plan and suddenly get hit with a bill because you and your Japanese pen pal like to use emoticons or emoji.

    IF texts are failing to be sent through iMessage then there should be options within iMessage to warn users or strip any MMS from text to ensure a user doesn't get added charges.
     
  16. thelatinist macrumors 603

    thelatinist

    Joined:
    Aug 15, 2009
    Location:
    Connecticut, USA
    #16
    If texts are failing to be delivered as iMessages, it's because the recipient's phone is off or has no signal. If they are being sent as SMS/MMS, it is because the sender has not turned off that option in settings. I fail to see how this is Apple's fault.
     
  17. Calidude macrumors 68000

    Calidude

    Joined:
    Jun 22, 2010
    #17
    All you have to do to avoid that is NOT have your Japanese penpal's international number in your contacts. Just his email address. Then the message app can't send anything but an iMessage via his email.
     
  18. YoYoCome macrumors newbie

    Joined:
    Apr 17, 2010
    #18
    Yea, but it doesn't mean his Japanese penpal will have his email address set up on his iPhone as Receive At. Maybe the email address is only being used for the Japanese penpal's iPad.

    Just turn off your "Send As SMS" is the solution. iMessage will let you know if the receiving party is getting your message or not. If you've sent a message and NOTHING shows underneath the text bubble, that means the receiving party currently does not have access to iMessage. iMessage will queue your messages until the receiving party has access to network or Wi-Fi. When the message is successfully sent through, it will say "Delivered" underneath the text bubble. (if the receiving party turned ON "Send Read Receipts" then it will show "Read")
     
  19. The General macrumors 601

    Joined:
    Jul 7, 2006
    #19
    You have a problem with iMessages delivering SMS/MMS some times, so your solution is to not use iMessages and use SMS/MMS 100% of the time? :rolleyes:
     
  20. Greenstick macrumors newbie

    Joined:
    Mar 14, 2009
    Location:
    UK
    #20
    Turning off the ability to send all iMessages as SMS/MMS doesn't really solve the issue though.

    There may be some iMessages I might be ok getting charged for, perhaps local ones are ok, but more expensive international ones not. Or it might depend on how important the message is, or what time of day I'm sending.

    So the 'solution' of going into Settings and adjusting how I send iMessages for each and every message is not a very good solution. And not very Apple-like.

    As urkel has suggested, the real solution is for the iPhone to recognise when it can't send an iMessage, tell me, and then offer the options for sending as SMS/MMS, queuing as an iMessage, or cancel.

    I've sent feedback to Apple about it.
     
  21. Moccasin macrumors 6502a

    Moccasin

    Joined:
    Mar 21, 2011
    Location:
    Newcastle, UK
    #21
    Wirelessly posted (Mozilla/5.0 (iPhone; CPU iPhone OS 5_0 like Mac OS X) AppleWebKit/534.46 (KHTML, like Gecko) Version/5.1 Mobile/9A334 Safari/7534.48.3)

    It would be worth an extra option which allows you to turn off SMS for international messages. That way, if you're messaging a friend abroad or you're travelling then you don't get charged. Otherwise it would have to be an option for each contact which is rather clunky. The existing switch will still be good for travelling though.

    I tried out iMessage with a friend in New Zealand who I wouldn't normally txt - just contact via Facebook - so I agree this could be an issue if you're often using it for that.

    I haven't turned off Send as SMS simply because I hardly send messages that way and can use Whatsapp.

    Suggest the OP gets/keeps WhatsApp until Apple add a new option
     
  22. marksman macrumors 603

    marksman

    Joined:
    Jun 4, 2007
    #22
    Wirelessly posted (Mozilla/5.0 (iPhone; CPU iPhone OS 5_0 like Mac OS X) AppleWebKit/534.46 (KHTML, like Gecko) Version/5.1 Mobile/9A334 Safari/7534.48.3)

    All of this.
     
  23. marksman macrumors 603

    marksman

    Joined:
    Jun 4, 2007
    #23
    Wirelessly posted (Mozilla/5.0 (iPhone; CPU iPhone OS 5_0 like Mac OS X) AppleWebKit/534.46 (KHTML, like Gecko) Version/5.1 Mobile/9A334 Safari/7534.48.3)

    Th problem is if you have someone who is frequently having IMessages sent as SMS then one of you has an accessibility problem. Some people I iMessage we have never had a message sent via SMS and we do it all the time.

    If you have a specific circumstance where you or your friend regularly are not accessible and dont have a text plan then turning off SMS makes perfect sense.

    Or as others noted send only via email. For these people create two contacts, one with only the iMessage email. If it does. It go through you can choose to send it via SMS.

    Personally I would be trying to understand why it is sending as SMS so often as in my experience and a few others I have talked with that fallback almost never happens
     
  24. Greenstick macrumors newbie

    Joined:
    Mar 14, 2009
    Location:
    UK
    #24
    I guess the slightly hysterical thread title doesn't help (its an issue but its not 'massive'), but its disappointing how defensive people get on here when all you're trying to do is suggest an improvement to an Apple service.
     
  25. steve-p macrumors 68000

    steve-p

    Joined:
    Oct 14, 2008
    Location:
    Newbury, UK
    #25
    Situation normal ;) If Apple didn't do it yet, it can't be worth doing. Then if they do, it's all what a great idea, etc. Lol.
     

Share This Page