Massive time machine issue, please help!

Discussion in 'Mac Accessories' started by ftbtef, Sep 3, 2011.

  1. ftbtef, Sep 3, 2011
    Last edited: Sep 4, 2011

    ftbtef macrumors newbie

    May 29, 2011
    Hi, I recently inherited my dad's old MacBook Pro. He had used Time Machine to back up his data. I wiped its hard drive with no security options. He tells me he has delete the sparse bundle for it. When I had moved, I wiped my old iMac with 1-pass security. Now I have been trying to get rid of my old iMac backup. First I accessed the Time Capsule from the MacBook. I attempted to delete the old sparsebundle (drag to trash, cmd-delete, etc). The little trash window opened saying it was deleting. However, the progress bar was just the red and blue stripes, as if it were preparing, and the bottom said Items to delete: 0. I left it for hours and came back, and it hadn't changed. Next I attempted to go to Show package contents, and then the bands folder, but even trying to erase one of the "bands" gave me the same never-ending "0 items to delete" progress window". Becoming frustrated, I went onto the Time Machine Backups drive that mounts when there is a backup going. I don't know how this drive appeared, since the Time Capsule is too full for the MacBook to back up, and it hasn't backed up yet. Anyway, I went on the drive, opened Backups.backupdb, and I saw that a bunch of old backups from when my dad owned this computer were in the backups folder. (This is strange, since he said he deleted his backup. Maybe it's because I didn't use security options when I wiped the MacBook's keyboard.) For no reason other than being confused and frustrated, I dragged every single backup from the Time Machine Backups drive into my Trash. Then I tried to empty the trash. It began saying it was emptying, then began with a progress bar, but when it was full, the "items to delete" starting going into negative numbers, so if you checked every second it went something like 10, 5, 1, 0, -2, -5, etc all the way into the thousands. I then realized it might harm my computer to get rid of these, and stopped the buggy trash emptying process. (As a side note, I tried secure deleting the trash, and it gave me the "0 items to delete" progress bar like the sparsebundle. I have kind of created a cluster**** here.

    I need any help I can get here. My questions to you all are:
    1. How can I actually get rid of my old Time Machine backup from the iMac?
    2. Is it bad if I removed the old backups from my .backupdb folder (the ones from when my dad had the MacBook)? (I don't need them, but I am wondering if it creates a problem with code or file structure. The backups folder still exists, but not the old backups of my dad's).
    3. If it is bad that I removed the old backups from .backupdb, how can I put them back?
    4. If it isn't bad, how can I get rid of them?

    Please help me. I am so worried about what might happen.

    EDIT: I had the deletion process of the old backups going on in the background. At around -33,000, I clicked the x to cancel the deletion, but to my surprise the trash has been emptied! I guess this is a good thing, but I am still wondering if it will create problems if they are gone.

    EDIT: Woke up this morning after letting the delete process run on the sparsebundle all night. It worked. I guess patience is a virtue :)

Share This Page