MathType and Pages no longer playing nice

Discussion in 'Mac Apps and Mac App Store' started by pubb, Feb 18, 2013.

  1. pubb macrumors member

    Mar 13, 2007
    I've used MathType with Pages without any issues for quite a while now. Until very recently, the process for inserting an equation into a document was very straightforward:
    1. Within Pages, I would choose Insert > MathType Equation and MathType would launch.
    2. I would create the equation from within MathType
    3. I would hit the red 'close window' button in the MathType window
    4. MathType would close immediately and the equation would be in my Pages document.

    All of a sudden, the behavior has changed: now when I attempt to close MathType, I get the typical "document save" dialog. To insert an equation, I now have to save the equation and then import it using the Insert > Choose menu options from within Pages.

    Here's what I've tried so far:
    • Uninstall/Reinstall MathType
    • Trying from within other apps (e.g Keynote)
    • Pulled MathType and Pages plists

    Any suggestions for troubleshooting?


  2. jdelgado macrumors regular

    Oct 25, 2009
    Something similar happened to me, but with Keynote. I tried the same things as you. Restarting my MBP solved the problem.
  3. pubb thread starter macrumors member

    Mar 13, 2007

Share This Page