MATLAB file association after installing Xcode

Discussion in 'Mac Programming' started by iamvincent, Apr 26, 2010.

  1. iamvincent macrumors member

    Joined:
    Feb 6, 2010
    #1
    Hey guys, before I installed Xcode, my .m files in matlab has one icon, but after installation of Xcode, the icode changed to that blue 'm' associated with Xcode as the default program to open it. Can anyone please lemme know how to turn off this kinda association and go back to MATLAB being default?

    Also I think another problem also due to installation of Xcode is that if I choose workspace from memory in Matlab, it will show the directory does not exist which actually it does. Can some one shed some light on this please? Thanks in advance.
     
  2. balamw Moderator

    balamw

    Staff Member

    Joined:
    Aug 16, 2005
    Location:
    New England
    #2
    The first one is easy.

    Select a .m file in Finder,
    right click, Get Info (or Command-I)
    Open With -> Select "MATLAB"
    Click the "Change All" Button.

    don't know what you mean by workspace from memory. I can't see that in any of my menus with MATLAB 2010a.

    B
     
  3. iamvincent thread starter macrumors member

    Joined:
    Feb 6, 2010
    #3
    Thank you for the first one. For the 2nd one, i meant that there is small triangle point downwards on the top, by clicking that, you 'll get a menu to choose from the recent workspaces you've used.

    And the problem is that even though the directory i specified exists, matlab says it does not. I can circumvent this by specifying workspace at other places but still this bug bums me out, you know, knowing something is not working correctly with your software....

     
  4. balamw Moderator

    balamw

    Staff Member

    Joined:
    Aug 16, 2005
    Location:
    New England
    #4
    Workspaces or folders? In mine what you describe seems to recall current folders, and it doesn't give me any errors even though I have Xcode installed...

    Maybe you should clear the history (from File -> Preferences -> Current Folder) and try again.

    Is there anything special about your folder names? Do they contain spaces? Are they on a network share or other drive that might not be mounted/available? ...

    B
     
  5. iamvincent thread starter macrumors member

    Joined:
    Feb 6, 2010
    #5
    yes, I mean the name of the folder. I tried to clear the history, but it didn't help. And I just now even reinstall my matlab, still not help either.....

    file name: AR_switching_MCEM, and when i click on the folder in that drag-down menu, it says:

    ???Error using ==> cd
    Cannot cd to /Users/........(the specific directory)(Name is nonexistent or not a directory).

    But it is! I can instead of using that small triangle but to use '...' next to it to specify the same directory, and that works fine. I hope I explain myself clearly. Thank you so much, balamw!


     
  6. balamw Moderator

    balamw

    Staff Member

    Joined:
    Aug 16, 2005
    Location:
    New England
    #6
    You might want to ask in a MATLAB specific forum like http://www.mathworks.com/matlabcentral/newsreader/

    However it just seems like the usual kind of unix error where a pathname contains spaces that are not escaped or otherwise protected. If that's the case, relocating your files to another folder without characters that need escaping would help.

    Can you post the output of "ver" from the MATLAB command line.

    B
     
  7. iamvincent thread starter macrumors member

    Joined:
    Feb 6, 2010
    #7
    ack! you are right! i changed the folder name, then it works, it used to MCEM, all capital and now i changed it 'mcEM'..... Don't remember the title cannot be all capital...... Thank you so much!

    Cheers
    H.

     

Share This Page