"Matrix like" green character display glitches

Discussion in 'iMac' started by akm3, Aug 2, 2014.

  1. akm3 macrumors 68020

    Joined:
    Nov 15, 2007
    #1
    My iMac has started intermittently developing some weird not letters but ascii looking green flashing characters in the background (through windows, down to the desktop) that come and go.

    I assume my video card is starting to go bad? It's the Mid 2010 27" iMac with the Radeon 5750.
     
  2. MartinAppleGuy macrumors 68020

    MartinAppleGuy

    Joined:
    Sep 27, 2013
    #2
    Could you post a screenshot/video the next time it happens. Really helps us help you :) Does sound like a GPU problem though. But by any chance to do have any 3rd party software from the internet that you can't 100% trust? Could also be a Trojan Horse application that is doing this.
     
  3. scaredpoet macrumors 604

    scaredpoet

    Joined:
    Apr 6, 2007
    #3
    More than likely it's a bad GPU, and the logic board will need to be replaced.
     
  4. akm3 thread starter macrumors 68020

    Joined:
    Nov 15, 2007
    #4
    Well, now it won't boot at all.

    Any idea what iMac logic board replacements costs these days?
     
  5. scaredpoet macrumors 604

    scaredpoet

    Joined:
    Apr 6, 2007
    #5
    US $789.00, used.

    Check with Apple, it's possible their repair costs are similar or only slightly more.
     
  6. akm3 thread starter macrumors 68020

    Joined:
    Nov 15, 2007
    #6
    Great site, didn't know about it.

    Ouch at that price I might as well just get a new one.
     

Share This Page