Mavericks and Teamviewer. Is anyone else having a problem with this combo?

Discussion in 'OS X Mavericks (10.9)' started by KTK1990, Jun 14, 2013.

  1. KTK1990 macrumors 6502

    Dec 26, 2008
    I live about 500 miles from my iMac and had some family members help me install Mavericks on my external hard drive I use for beta testing software. Running Mountain Lion Team viewer worked perfectly fine, I was able to reformat the disk and start the install of 10.9. Via phone call I was able to guide my sister and mom into getting past the setup screens and to the desktop on 10.9.

    But every time I try to use Team viewer to remotely login, I can't. When I use my laptop (Windows 7, and in a virtual machine of Win8) I get a window I've never seen before that gets stuck at "Initializing Display Parameters" I gave it about 30 minutes once before I gave up. When I use my iPad 2 all it says is Connecting and has a spinney white circle.

    Internet works fine on the iMac but Team viewer doesn't and I am not sure why.
  2. jozeppy26 macrumors 6502


    Jul 8, 2008
    St. Louis
    I just helped a family member from my mac (I have 10.9, he has 10.7) and had no problems. But, I've never tried remote desktop to a 10.9 machine, only from.
  3. KTK1990 thread starter macrumors 6502

    Dec 26, 2008
    Thanks and interesting, from that I can see Team Viewer on Mavericks works controlling others, but not sure if I can take over a 10.9 machine.

    When I was on the phone with my mom, I tried having her connect to my Win 8 Virtual machine, she was able to control my VM from the Maverick Mac, but the switch sides button she said was grayed out and said something about her being the host is why it is grayed out.
  4. turbotoes macrumors regular

    Nov 24, 2010
  5. crysys macrumors newbie

    Jun 14, 2013
    I don't own a Mac but your post is the only one I've been able to find that matches my problem. I get the same initializing display screen when connecting to a PC running Ubuntu 13.04 from either a Windows 7 laptop or an Android phone or tablet. So I'm guessing this is a problem in Teamviewer itself if it's happening cross platform.

    Do you know if Teamviewer uses the same WINE back end to run on OSX as it uses in Linux?
  6. KTK1990 thread starter macrumors 6502

    Dec 26, 2008
    Sorry but I have no clue.

    What I found that actually works is Logmein. I was able to remotely control my Maverick Mac from 500 some miles away on my Windows 8 virtual machine.
  7. actisys macrumors newbie

    Jun 16, 2013
    The only problem i met was unable to file transfer .. When open up the File Transfer there is no disk found on the opposite side.

  8. sreknob macrumors newbie

    Jun 2, 2013
    Not only 10.9 it seems.
    I'm now having the "Initializing display parameters" screen when attempting to connect to a 10.8 macbook pro from windows 7. Connection terminates directly from this waiting screen after a few seconds. Log file shows:
    The following activities didn't finish properly: Remote Display Parameters
    G1   SCB::SendRemoveParticipant: victim=[0,0], forceEndMeeting=0
    G1   Connection closed by user
    S0   CStreamManager::~CStreamManager(): LimitedStreams: AccumulatedTime: 0ms, 2 limited sends triggered 0 waits, 0 limits reached
    S0   CT89 CT.Run.LoopEnd
    S0   CT89 CT.Disconnect
    Guess will have to dig deeper...
  9. dBeats macrumors 6502a


    Jun 21, 2011
    I'm using TeamViewer 8.0.16901 and Mav DP6 without any problems. I'm usually the client though and my developers start the meeting, generally from a Linux machine. Not sure if that's helpful or not...
  10. petieg macrumors newbie

    Jul 31, 2007
    It's come and go with me

    It seems as though you can remote to Windows devices just fine, but i'm having trouble connecting to some Mac's. I'm running 10.9 -- they are running a mix of 10.6-10.8 -- and there is no rhyme or reason why i can't connect. Teamviewer themselves admit compatibility problems -- Germany HQ says "Unfortunately, this is a beta version and currently it is not compatible with TeamViewer. Once the official release comes out, our developers will be able to work on a solution. At this time we have no information on when the official release will come out." Some TV employee in Florida suggesting downloading the .gz.tar file (i'm assuming he means the Linux version), but i don't want to go down that path.

    I've found w/ certain machines, that no combination works. :mad:
  11. frason macrumors newbie

    Sep 10, 2009
    Updated to latest Teamviewer version and it works fine here now.
    Didn't work with previous version to remote control Mavericks for me.
  12. Eneasilvio macrumors newbie

    Oct 26, 2013
    Teamviewer in Mavericks connecting from PC to Mac

    In Osx Mavericks go to Systemsettings, then Privacy, then General and allow programs from every source.
  13. PaperQueen macrumors 6502


    Aug 16, 2007
    Just this side of insanity (Minneapolis)
    It worked? I've been hearing LogMeIn didn't work in Mavericks, on either end of the connection. Their support rep told me LMI isn't Mavericks-compatible, and to expect problems.

    Ahhh, the fun side of being an early adopter when a new OS rolls out.... :rolleyes:

    Would love to update, but LogMeIn and OpenOffice need to function before I make the jump. Am considering TeamViewer as a backup, but threads like this one make me nervous.
  14. KTK1990 thread starter macrumors 6502

    Dec 26, 2008
    Teamviewer does not work at all for me, I've used Logmein for the past few months and it has worked perfectly fine for me. I do use the web version however on my windows pc (and iPhone app). I was able to send files near perfectly (It could not find my desktop on windows side).
  15. alksion macrumors 68000


    Sep 10, 2010
    Los Angeles County
    Simply update the app to version 9. Works like a charm.
  16. 24hrpizza macrumors member

    Dec 19, 2013
    whew - this makes me relieved. was about to install team viewer, got worried it wasn't going to work. problem sovled! :) thanks!
  17. alksion macrumors 68000


    Sep 10, 2010
    Los Angeles County
    Of course. Glad I can help.
  18. AChristi macrumors newbie


    Oct 12, 2015
    I have a similar problem since I upgraded my iMac to 10.11 (El Capitan). Connecting to it from any other station is no longer possible. Worked fine under 10.9 & 10.10...

    Kr, Arnd

Share This Page

17 June 14, 2013