Mavericks Archived my Mail Accounts?

Discussion in 'OS X Mavericks (10.9)' started by Evo-L, Jun 30, 2013.

  1. Evo-L macrumors member

    Joined:
    Feb 28, 2008
    #1
    I am not sure whats going on here... Mavericks archived all of my old gmail emails for some reason, but only on one account. It shows about 5000 archived messages and nothing in the standard "inbox". Is this some new feature or something I have to fix somehow?

    Does anyone know anything about this?

    Thanks :apple:
     
  2. Evo-L thread starter macrumors member

    Joined:
    Feb 28, 2008
    #2
    I needed to rebuild the mailboxes.

    But Im still showing an Archive folder which Ive never had before. It appears to simply mirror my 2 gmail accounts. I don't like it, how do I get rid of it?
     
  3. Bear macrumors G3

    Joined:
    Jul 23, 2002
    Location:
    Sol III - Terra
    #3
    Log in to gmail via a web browser and delete the Archive Tag.
     
  4. jb510 macrumors regular

    jb510

    Joined:
    Sep 19, 2007
    #4
    Yes and no.

    Behavior changes in 10.9. Mail is Gmail label aware and things that used to be mapped as folder [Gmail]All Mail is a nice neat Archive label instead.

    To reverse this behavior you can roll back to 10.8. I suspect you could also force setting up your gmail as a dumb IMAP server (not gmail) and Apple Mail might see it the old way but haven't tried.
     
  5. krdnha macrumors newbie

    Joined:
    Jun 22, 2012
    #5
    I have a problem with mail.
    The mails doesn't appear correctly. They are aligned to the right and some paragraphs are cutted on right side and I cant scroll horizontally.
     
  6. Jab00 macrumors regular

    Joined:
    Jun 12, 2012
    Location:
    Boulder,CO
    #6
    Since you seemed the most knowledgable about this I quoted you but really any help from anyone would be awesome. So I realize this new archiving feature is part of OSX 10.9 but now that its archiving my gmail mail whenever I hit delete on a message it sends it to trash and then reappears in my inbox with a little thing under the time stamp that says "Gmail Trash". All it takes from here is another delete and its out of my inbox permanently... any way to make it so I dont need to go and delete every email twice????
     
  7. Spikestrip, Jul 23, 2013
    Last edited: Jul 23, 2013

    Spikestrip macrumors member

    Spikestrip

    Joined:
    Apr 1, 2011
    Location:
    California
    #7
    Here's what I did to fix this:


    First I quit Mail.

    Then I went into Gmail on the web, and into settings, then labels. I uchecked the box under System Labels for All Mail to show in IMAP.

    I opened Mail after that, and noticed that my inbox was empty, and the archive folder was gone.

    I quit Mail.

    Then I went back to the settings and checked the same box that I unchecked.

    After opening Mail again, it synced up all the mail just like I would expect. I did not touch the Archive setting or flag at all.

    I did this for two different Gmail accounts with the exact same success. The Archive folder is the same as the All Mail folder that you most certainly had before Mavericks. If you don't like it, the only option is to not look at it. It's part of how Gmail functions and you don't want to delete it.

    As far as not deleting, that is a "feature" of Gmail. The idea is that they give you so much storage for email that you should not need to delete email, rather just archive it. However, after the fix I went through, deleting seems to work the way I want, as in it puts the message in the trash on the client and the server. As far as I can tell, if you follow the steps above, Mail should do exactly what you want. The process took just a few minutes, and another several syncing the email back. Maybe 15 minutes total.

    Cheers
     
  8. cookies! macrumors 6502

    Joined:
    Jul 3, 2011

Share This Page