Mavericks - extremely slow to list files when selecting files in finder and Safari

Discussion in 'OS X Mavericks (10.9)' started by iosuser, Oct 30, 2013.

  1. iosuser macrumors 6502a

    Joined:
    Mar 12, 2012
    #1
    Has anyone noticed sometimes when trying to browse files in the finder or when selecting a file to attach in Safari, that it takes a long time for the list of files to show? Say I want to attach a picture in Safari, such as if I wanted to attach a picture to this post, when the finder menu pops up for me to select files, no files will show for 10-15 seconds times, with the gear spinning incessantly.

    This is happening on a fresh out of the box Haswell rMBP and my 2012 rMBP upgraded from ML to Mavericks. It is extremely annoying.
     
  2. Turrican2000 macrumors newbie

    Joined:
    Oct 23, 2013
    #2
    Yes! I got the same experience. (late 2008, ssd)
     
  3. KimHansenDK macrumors 6502

    Joined:
    Jul 29, 2011
    #3
    I had the same problem - I removed some apps and reverted from open dns to default dns. One of these things must have solved it because it has not happened since...
     
  4. audiomixer macrumors member

    Joined:
    Feb 24, 2007
    Location:
    Idaho
    #4
    What does DNS have to do with this? I have the same issue BTW. It is most irritating. Running 2010MBpro with SSD.
     
  5. KimHansenDK macrumors 6502

    Joined:
    Jul 29, 2011
    #5
    I have no idea. I am just listing the things I have done before I got it to work. Not that the DNS have anything to do with it - it could just as well be some app that I removed.
     
  6. ashleykaryl macrumors regular

    ashleykaryl

    Joined:
    Jul 22, 2011
    Location:
    UK
    #6
    I've been experiencing the same problem on a Mac Pro and just found the cause. In my case it was an attached external drive and when I eject the drive everything returns to normal but this was never a problem under Mountain Lion. Generally speaking I want to keep that drive attached for Time Machine backups so I'm really waiting for Apple to fix this with an OS update.
     
  7. T'hain Esh Kelch macrumors 601

    T'hain Esh Kelch

    Joined:
    Aug 5, 2001
    Location:
    Denmark
    #7
    I have experienced general slow disk IO after upgarding to Mavericks. Quite weird actually.
     
  8. kastorff macrumors regular

    kastorff

    Joined:
    Oct 7, 2006
  9. lunaoso macrumors 65816

    lunaoso

    Joined:
    Sep 22, 2012
    Location:
    Boston, MA
    #10
    Same here. Really annoying when browsing files in Finder.
     
  10. apunkrockmonk, Nov 9, 2013
    Last edited: Nov 9, 2013

    apunkrockmonk macrumors 6502a

    apunkrockmonk

    Joined:
    Nov 20, 2005
    Location:
    Rochester, NY
    #11
    Also experiencing this on my Fusion Drive.

    I have no external drives connected to this machine but in addition to the Fusion Drive there are several other internal drives.
     
  11. Riverrun macrumors regular

    Joined:
    Jul 11, 2007
    Location:
    ~
    #12
    I have the same problem, but only on my Mac Mini which is the newest computer that I have. My 2009 MacBookPro is fine and so is my 2009 iMac. I'll try unmounting the External Drive when I get home and see if that makes a difference.

    All in all, Mavericks is the buggiest release since Snow Leopard. I have other problems as well but I won't list them here.
     
  12. ashleykaryl macrumors regular

    ashleykaryl

    Joined:
    Jul 22, 2011
    Location:
    UK
    #13
    The strange thing is that since ejecting and reconnecting that external drive earlier today I haven't had the problem since. I'll keep an eye on it.
     
  13. aaronvan Suspended

    aaronvan

    Joined:
    Dec 21, 2011
    Location:
    República Cascadia
    #14
    Very annoying!

    Absolutely. When I attach a file to an email, a finder window opens and I must sit and watch the little spinner thing for a good thirty seconds. Very annoying, really. I'm surprised this isn't getting much more attention. It's a very important bug and almost enough to make me wish I hadn't upgraded to Mavericks.

    Could it just be affecting a sliver of the Mac user base?
     
  14. blitzcraig macrumors newbie

    Joined:
    Dec 5, 2013
    #15
    Same Issue

    I have the same slow save dialog issue with Mavericks. I did a clean install too. I have a 2011 iMac. When I use any program and a save dialog pops up, the finder spins for 10-20 seconds and there are no folders visible (except for the sidebar). This is especially annoying in iPhoto where I export photos to different folders within my Pictures folder. I cannot see a list of subfolders until it stops spinning. It's like it has to reindex my drive every time I go to save something. After it does it once, it seems to act normally for the rest of that session, until it sleeps or is rebooted again, that is.
     
  15. Mr. Retrofire macrumors 601

    Mr. Retrofire

    Joined:
    Mar 2, 2010
    Location:
    www.emiliana.cl/en
    #16
    The same happens also on a fresh installation of Mavericks 10.9.0 (MAS version) inside a Virtual Machine (VM). So it is certainly not a hardware problem, and has nothing to do with third party apps.

    The cause is Apples ZERO quality management, regarding OS X 10.9.0.
     
  16. JohnDoe98 macrumors 68020

    Joined:
    May 1, 2009
    #17
    I think it's related to App nap, i.e. Finder goes to sleep and so we have to wait for Mavericks to relaunch it and then load the contents of that directory. It's infuriating to have this on a brand new system with SSDs. If it is app nap, then disable the feature for Finder...
     
  17. afin macrumors member

    afin

    Joined:
    Feb 17, 2012
    #18
    Is there really "ZERO" quality management?
     
  18. ls1dreams macrumors 6502

    Joined:
    Aug 13, 2009
    #19
    Is anyone running 10.9.1 beta 2? Curious if it's resolved these lags.
     
  19. JorgeLomeli macrumors regular

    JorgeLomeli

    Joined:
    Nov 29, 2008
    Location:
    Monterrey, MEXICO
    #20
    8 simple steps to fix the "beach ball" in Finder:

    1. Open Terminal

    2. Type: sudo nano /etc/auto_master
    (using nano instead of vi makes it a little more user friendly)

    3. arrow down to the command:
    /net -hosts -nobrowse,hidefromfinder,nosuid
    and add a # to the front so it reads:

    #/net -hosts -nobrowse,hidefromfinder,nosuid

    4. press control + X to exit

    5. Press Y to save

    6. press Enter

    7. Close Terminal

    8. Reboot

    Cheers! ;)
     
  20. Shazaam! macrumors member

    Shazaam!

    Joined:
    Apr 12, 2009
    #21
    It seems that this only happens in the first Open or Save dialog box encountered after a system start-up. Perhaps this is to speed up startup by not reading the start-up drive's document file structure into memory?
     
  21. ls1dreams macrumors 6502

    Joined:
    Aug 13, 2009
    #22
    What exactly does that change do?
     
  22. Ganesha macrumors regular

    Joined:
    Aug 4, 2009
    #23
    It disables network shares from automatically mounting. This fix will break things if you use such features.
     
  23. greatcreative macrumors newbie

    Joined:
    Jan 15, 2014
    #24
    This worked for me. (thanks)

    I was having this problem with my new MacBook Pro 15" (Retina).
    Processor 2.3 GHz Intel Core i7
    Memory 16 GB 1600 MHz DDR3

    I removed the unattached drive and it seems to be working much better. Still slow for SSDs, but greatly improved since I tried this solution.

    Never had these problems with my late 2009 MacPro. Wish I never replaced it.
     
  24. AppleGoat macrumors 6502a

    Joined:
    Oct 14, 2010
    #25
    I've been having this problem. I have two drives in my MacBook Pro. When I open a finder window for the drive in the optibay, the icons instantly appear. But, when I open a finder window for my main drive, on which Mavericks is installed, it takes a while for the icons to appear, at least the first time I do it after booting.

    Ejecting the second internal drive doesn't do anything.
     

Share This Page