Mavericks Font Book Issue

Discussion in 'OS X Mavericks (10.9)' started by create90mph, Oct 27, 2013.

  1. create90mph macrumors newbie

    Joined:
    Aug 3, 2009
    #1
    Anyone else been having problems with Font Book since upgrading? The Install now button no longer works, and dragging fonts directly into Font Book works only 50% of the time.

    Any ideas or a workaround?
     
  2. texasex95 macrumors newbie

    Joined:
    Jun 11, 2009
    #2
    Same issue with some fonts

    I'm having the same issue. FontBook acts like it is installing the fonts and then they are never there. Someone suggested installing Onyx to clean up my font cache but that didn't work either.

    Any other ideas would be greatly appreciated.

    Thanks.
     
  3. cory8itall macrumors newbie

    Joined:
    Nov 11, 2013
    Location:
    Amsterdam
    #3
    Fontbook Amnesia

    Same problem here. I open fonts from Finder, the install window appears, I click the install button, it appears as though something is happening, but the font rarely ever actually installs. Would love to find out what's going on. I'm a graphic designer and fonts are my life.
     
  4. Samuel Gordon macrumors member

    Joined:
    Aug 29, 2008
    Location:
    Czech Republic
    #4
    I have a problem with Font Book in Mavericks too but of a different kind. I can't choose collections. Even if I highlight or double-click (or whatever) another collection, only fonts from the previous one appear :confused: One solution is select a desired collection, type something in the search field and then remove the search phrase. Voila - the fonts of the desired collection appear but that's it - switching to another one fails again.

    It's working after the app restart but it's so annoying.
     
  5. 835153 Guest

    Joined:
    Aug 5, 2013
    #5
    I get this problem too. Looks like the font installs but nothing appear nor is it installed.
     
  6. etcameron macrumors newbie

    Joined:
    Dec 4, 2013
    #6
    I have also been wrestling with this problem since upgrading. It's been especially troublesome since I am also a graphic designer and there is one font family I usually load from a file server that I need for work daily but haven't been able to access for weeks now.

    I've tried adding the font simply by opening Font Book, I've tried the Validating Font action but neither have worked thus far. Has anyone tried contacting Apple directly to see if they've been any help?
     
  7. Solertia macrumors newbie

    Joined:
    Mar 24, 2014
    #7
    Bumping this as I've been encountering this too, except I haven't gotten ANY fonts to install so far. The files go into ~/Library/Fonts, but don't appear in Font Book or any other apps.
     
  8. oldtimemacuser macrumors newbie

    Joined:
    Apr 14, 2014
    #8
    Fontbook functionality gone with Mavericks

    Bump again, as this Fontbook issue is very annoying. I use Fontbook to scroll through fonts and families in order to pick or match a font that is not the usual. I have a few thousand fonts on the mac. None can be seen in Fontbook. The usual help forums are nonsense remedies, utilities, disk failure etc.
    When running disk repair be sure to physically unplug all devices from the mac, including internet, you'll find your disk is fine in most cases.
    Apple issues out a free OS upgrade, albeit everything runs a little better except for this MAJOR glitch.
     
  9. Bl!zz macrumors newbie

    Joined:
    Apr 11, 2014
    Location:
    The Netherlands
    #9
    I don't have this problem. Maybe there's a (preference?) file somewhere you can delete and try to fix it with…

    I'd suggest a reinstall or new user account if those would fix it for you.
     
  10. oldtimemacuser macrumors newbie

    Joined:
    Apr 14, 2014
    #10
    Bl!zz:
    Thanks for the reply
    So far everything else is working in my other programs in Mavericks. Tried Safe Mode and voila, fonts appear as before. Restart in normal user mode, not so great. I can now highlight a folder, such as All Fonts, go to search and select All in drop down menu, hit return, and the fonts magically reveal themselves as Samuel above states. Custom View won't work and fills the box with some latin gibberish. If I do anything (like delete a foreign alphabet typeface or change collection) everything disappears all over again.
    Tried trashing preferences, yadyadyada...nothing.
    I wouldn't bother reloading new OS. Will wait for an upgrade and make do or buy a 99¢ app from applestore. Will try different user as you suggest, but if you don't hear back, it means it didn't work either.
     
  11. pfackelmann macrumors newbie

    Joined:
    Apr 26, 2014
    #11
    Even more weird

    I opened Font Book the first time and got a message:
    "Font Book" not supported on this type of Mac*

    Restoring from TimeMachine:
    Same

    Reinstalling it from "MacOSXUpdCombo10.9.2":
    You can't open "Font Book" as it is possibly damaged or incomplete*

    *Translated from German.

    Any idea?

    Regards

    Peter
     
  12. oldtimemacuser macrumors newbie

    Joined:
    Apr 14, 2014
    #12
    To Blizz,
    I tried a different User - yep, there doesn't seem to be a problem. Not sure what settings to change in my usual User mode to end the glitch I'm getting.

    To pfacklemann,
    As far as I know fontbook is part of the new OS so should install its upgrade to Mavericks. See if the install you did left 2 Fontbook Applications in your Applications Folder.
     

Share This Page