Mavericks full screen worse than Mountain Lion

Discussion in 'OS X Mavericks (10.9)' started by blahbrah, Nov 10, 2013.

  1. blahbrah macrumors 6502

    Joined:
    Nov 9, 2006
    #1
    Hey everyone,
    Mavericks has been causing a bunch of problems for me in full screen mode on my second monitor. If I use MPlayerX to play local files or streaming anything via Google Chrome there is a constant gray bar at the top or the menu. Is there any way to get this to hide?

    Thanks everyone!
     
  2. w0lf macrumors 65816

    w0lf

    Joined:
    Feb 16, 2013
    Location:
    USA
    #2
    Sounds like it could be a bug with those specific apps. I don't get this Gray bar you're mentioning if I watch a movie in full screen with VLC and I also don't see any bar watching youtube videos in full screen on my external monitor with Chrome Canary.

    You can also switch back to the old system in:
    System Preferences > Mission Control > (uncheck) Displays have separate Spaces
     
  3. chabig macrumors 68040

    Joined:
    Sep 6, 2002
    #3
    How did you get to full screen? It sounds like you're seeing the menu bar, which makes me think you only grew the player window to full size instead of actually going to full screen.
     
  4. hiutin macrumors newbie

    Joined:
    Mar 23, 2012
    #4
    I have the same problem, i guess those program is not fully ready for mavericks yet, give them time
     
  5. merckens macrumors newbie

    Joined:
    Feb 10, 2014
    #5
    If you open an application on your machine and drag its window over to your secondary monitor, the translucent menu bar will *always* show on the secondary monitor. The external monitor is a separate space (unless you've deselected that option in System Preferences, which is kind of a silly thing to do), so if you drag a window over to the second screen, the application is actually running out of your machine's space and not from the secondary monitor's space. So in the eyes of the external monitor, the focus is still on your machine's space when you're running a dragged VLC or browser window (or whatever application) in fullscreen mode on the secondary monitor. So it displays that obnoxious translucent menu bar.

    So long story short (too late!), literally all you need to do - there are other ways, but this is the easiest - is close the application, put the focus on your secondary monitor's space (by opening a finder window in that space or switching to an app already running that was opened in that space or using the dock from within that space, etc.), and then reopen the application from within the secondary monitor's space. Now when you go fullscreen, the menu bar won't be there, because the focus of the application is in the space it's running fullscreen in.
     

Share This Page