Mavericks giving me "service battery"

Discussion in 'OS X Mavericks (10.9)' started by Allan in T.Dot, Nov 4, 2013.

  1. Allan in T.Dot macrumors member

    Joined:
    Jul 14, 2010
    #1
    Hi all,

    Just noticed something and was wondering if it was just me. I'm using a 2011 MBA and a older 2008? MBP. I was previously using Lion and Snow Leopard respectively. After upgrading to Mavericks, I looked at my battery icon and I've been getting repeated "Service Battery" notifications that I did not see in the older OS. Anyone have similar issues?
     
  2. RedRaven571 macrumors 65816

    RedRaven571

    Joined:
    Mar 13, 2009
    Location:
    Pennsylvania
    #2
    Yep, got the same thing on my 2008 MBP; had it happen in the past when I upgraded to ML, disappeared when I went back to SL.:confused:

    Now I updated to Mav and its baaaacccckkkkk. However, the battery appears to be functioning as before so I am just ignoring it for now.
     
  3. eecyclone macrumors regular

    eecyclone

    Joined:
    Jul 10, 2013
    #3
    My mid-09 macbook pro started having a service battery indicator about a year ago. I think it happened shortly after the upgrade to mountain lion. It comes and goes sporadically, but it still seems to be working the same. The only issue is it doesn't always tell me how much time I have left on the battery or how what percentage is remaining. I'm waiting for it to conk out and then I will be upgrading to a rMBP.
     
  4. SolRayz macrumors 6502a

    SolRayz

    Joined:
    Jul 5, 2007
    Location:
    Ft. Lauderdale
    #4
    I have the same "Service Battery" warning since upgrading to Mavericks on my Mid '09 MBP. I'm surprised this hasn't garnered more attention in MR's.:confused:
     
  5. GGJstudios macrumors Westmere

    GGJstudios

    Joined:
    May 16, 2008
    #5
    The "Service Battery" indicator will appear when your battery health drops below 80%. That has been true sine long before Mavericks.
     
  6. Phazer macrumors member

    Joined:
    May 19, 2010
    Location:
    London, UK
    #6
    Happened to me too with one of the 10.9 DPs.
    Went away after a few days.
     
  7. jkkool macrumors member

    jkkool

    Joined:
    Aug 22, 2010
    #7
    Why there is service Battery on my MBP after maverick

    I just noticed that, i never opened battery sign since ages, i was just looking though it and found that, what is that for any clue.:mad::apple:
     

    Attached Files:

  8. Jimbo47 macrumors 6502a

    Joined:
    Jun 21, 2010
    #8
    Count me in on this too. I just noticed it. Definitely wasn't there last night though. Since it seems widespread I'll just ignore it for now.

    Edit: I just checked it again and its now displaying a time.
     
  9. jkkool macrumors member

    jkkool

    Joined:
    Aug 22, 2010
    #9
    I was selling my MBP and reinstalled Maverick, after that its gone, then last week i bought new rMBP and its fine there, so may be if you reinstall your OSX you will get rid of it, but let it stay there its doing nothing.
     

Share This Page