Mavericks GM killed off Bootcamp

Discussion in 'OS X Mavericks (10.9)' started by Sue De Nimes, Oct 10, 2013.

  1. Sue De Nimes macrumors 6502a

    Sue De Nimes

    Joined:
    Apr 10, 2012
    #1
    I have installed the GM of Mavericks and all has been fine.

    I just tried to boot into my Bootcamp partition and low and behold Mavericks seems to have removed my bootcamp partition from the boot menu.

    The partition is there and intact - it just isn't showing up as a bootable option.

    Any ideas on this?
     
  2. pastrychef macrumors 601

    pastrychef

    Joined:
    Sep 15, 2006
    Location:
    New York City, NY
    #2
    I've booted in to my Bootcamp drive on several occasions since installing Mavericks. No problems at all. I should mention that I have Bootcamp on a separate drive.
     
  3. mikecwest macrumors 6502a

    mikecwest

    Joined:
    Jul 7, 2013
    #3
    Did you re-partition your hard drive to install Mavericks in addition to an additional OSX partition? Did you re-format a partition?

    Depending on what method you used, you may have changed your partition map. Bootcamp windows installations depend on a certain partition map, and if you add a partition or change a partition, its possible that your windows is looking for the windows on the wrong partition. If you are running windows XP it should be a setting in your boot.ini file. In windows 7 you need to use BCEDIT.

    If the bootcamp partition is not the correct partition number, it won't show up in the startup disk preference pane.

    Can you see the option to boot from it if you hold the OPTION key while rebooting or starting your machine?
     
  4. iEnvy macrumors 65816

    iEnvy

    Joined:
    Jun 25, 2010
    Location:
    DFW
    #4
    You must've altered the partitions when you installed Mavericks. I boot up and out of Windows just fine.
     
  5. Sue De Nimes thread starter macrumors 6502a

    Sue De Nimes

    Joined:
    Apr 10, 2012
    #5
    I upgraded my current OSX installation. I didn't touch the partition map.

    I did resize the partitions a few months ago. When I did that I stopped being able to select Bootcamp from "Startup Disk". I could select it from the boot manager though by holding down the option key at boot.

    When I use the boot manager it now doesn't show.

    Does this sound like use of BCEDIT will remedy?

    I use BootCamp primarily for games. There isn't really anything on there that I can't afford to lose - however I don't want to have to download the 300GB of Steam games if I can avoid it.
     
  6. Manic Harmonic macrumors 6502

    Joined:
    Dec 4, 2011
    #6
  7. Sue De Nimes thread starter macrumors 6502a

    Sue De Nimes

    Joined:
    Apr 10, 2012
    #7
  8. Sue De Nimes thread starter macrumors 6502a

    Sue De Nimes

    Joined:
    Apr 10, 2012
    #8
    Ended up deleting the boot camp partition and reinstalling.

    400GB of games from Steam over the last few days downloaded. Thankfully I have an unlimited data allowance on my home connection.
     
  9. Manic Harmonic macrumors 6502

    Joined:
    Dec 4, 2011
    #9
    I really wish windows had something like time machine/migration assistant... My w7 install on my hack is kind of screwed up but a fresh install means days of work, like you just had to deal with. At least you got it sorted. You may want to look into something like WinClone to back up your boot camp install as a disk image.
     
  10. fs454 macrumors 65816

    Joined:
    Dec 7, 2007
    Location:
    Los Angeles / Boston
    #10
    If this ever happens again, you can access that partition with an NTFS utility like Paragon NTFS and copy the Steam data files before you erase your whole partition!
     
  11. Sue De Nimes thread starter macrumors 6502a

    Sue De Nimes

    Joined:
    Apr 10, 2012
    #11
    I did try several things to remedy. Unfortunately it looks like OSX did something funny with the partition table.

    I managed to gain access to the partition using Windows Recovery. The partition was smaller than it should have been and empty and there was a large amount of unallocated space.

    I have a 2TB HDD in my iMAC. I did originally have 300GB allocated for Bootcamp. I later resized this to 500GB using a non OSX partition manager. Evertything was fine except I could select the Bootcamp partition from "Disk Select" in OSX. I could see it in Disk Utility and boot to it no problem.

    When I got the the command prompt from my Windows boot disk I found that I had a 300GB partition that was pretty much empty. I also had 200GB of unallocated space.

    I will investigate Winclone. My gut feeling is it wouldn't have helped me. I am happy to back up (and do) any important data on my partition. Steam apps get installed and removed so frequently - I probably wouldn't back them up :(
     
  12. cal6n macrumors 68000

    cal6n

    Joined:
    Jul 25, 2004
    Location:
    Gloucester, UK
    #12
    I tried expanding my MBP Bootcamp partition and got to the same point as you. I never found a workable way to roll the unallocated space into the windows partition because the space is created between the OS X and Bootcamp partitions. Windows assumes it is always the first partition on the disc and will only allow partitions after itself to be absorbed.

    I too ended up reinstalling Windows.
     

Share This Page