Mavericks install fail - disk corrupted

Discussion in 'OS X Mavericks (10.9)' started by flux73, Oct 22, 2013.

  1. flux73 macrumors 65816

    Joined:
    May 29, 2009
    #1
    MBA 2010, upgrading from Mountain Lion. 256 gb SSD with 90gb free.

    As it was installing, a dialog box pops up on the screen and said something about the disk being corrupted. It gave me some disk utilities so I ran a verify disk. It identified a corruption and asked me to repair disk. But the "repair disk" option was greyed out and unselectable.

    So I rebooted into Recovery Mode per a poster's recommendation at Apple discussions and tried to repair disk from there. No go. Error message says it cannot be repaired and that I need to backup the disk. We'll I don't have an external hard drive or time capsule - just a 16 gb USB drive.

    I rebooted and tried the installation again. It seems to be going but I still have 15 min left.

    Hopefully it works, but just wanted post this in case someone else has this same issue. A lot of people over in an apple discussion group had the same problem. Have to admit i'm disappointed that such a huge install bug slipped passed Apple's QC.
     
  2. flux73 thread starter macrumors 65816

    Joined:
    May 29, 2009
    #2
    Well, it completed. Not sure why I had so many problems to begin with. So anyways, if you run into the same problem, try to reboot and reinstall - it seemed to work for me at least.
     
  3. tilit macrumors newbie

    Joined:
    Oct 23, 2013
    #3
    A similar error message popped up on my iMac (running next to latest version of 10.8) telling me my disk is damaged. I used Disk Utility to repair and verify the disk, both of which gave my HD a clean bill of health. However, the Mavericks installer no longer recognizes my HD, i.e. the HD doesn't come up as an option to install it to.

    When I attempt to reboot from my HD, same problem. The HD is not on the list. When I attempt to recover from a time machine backup, same problem: my HD is not recognized, so there's nothing I can recover to.

    Disk Utility still sees my HD.

    Any ideas?
     
  4. Marco9774 macrumors newbie

    Joined:
    Jul 30, 2012
    #4
    You need to wait a few minutes and then it appears as an instalation option, same happened to me
     
  5. talamera macrumors newbie

    Joined:
    Oct 24, 2013
    #5
    Same disk damaged message. Rebooted to repair partition by holding command-R at startup, selected Disk Utility. When I selected my hard drive and repair disk, first pass said it could not be repaired. I selected repair disk again and it "repaired" it. Then selected restart from apple menu in upper left corner and Mavericks now installing without problem.
     
  6. Vteditor macrumors newbie

    Joined:
    Oct 26, 2013
    #6
    iMac 10.6.8 to mavricks

    Hi all
    I have the same problem however when rebooting and holding Cmd -r I still have mavricks trying to install don't get the utilities option. When mavricks fails I then go to the disk utility at the top and try to repair from there. The repair disk option is shaded and I can't seem to get around this.
    Luckily I backed to my time machine but I can't seem to get the 'restore your system' to find the hard drive...

    Am stuck guys and need to get my machine running again for work. Will happily go back to 10.6.8 if the machine would let me.
    Any advise or ideas would be great thanks,

    Simon.
     
  7. macworkerbee macrumors 6502

    Joined:
    Jun 14, 2008
    #7
    I have the same problem. Mavericks killed my HD. It refused to repair so now I'm erasing and reinstalling mountain lion. I hope this works. At least I have a time machine backup :/
     
  8. AtlasRider macrumors newbie

    Joined:
    Oct 27, 2013
    #8
    Regarding the "Repair Disk" option being disabled, I ran into this as well. Make sure you have selected the "Macintosh HD" at the root level, instead of one of the sub-items (which are partitions).

    After selecting the Disk, as opposed to the partitions, the "Repair Disk" button should be enabled.

    Unfortunately after the Mavericks update, my disk seems to be unrepairable :mad:
     
  9. iMacprobook macrumors member

    Joined:
    Apr 6, 2010
    Location:
    UK
    #9
    This is not good, did my Mac Pro and office iMac, then my white MacBook ran into these problems too. Now reinstalling mountain lion :-((
     

Share This Page