Mavericks killed my new MBA?

Discussion in 'OS X Mavericks (10.9)' started by Nathan777, Oct 22, 2013.

  1. Nathan777 macrumors newbie

    Joined:
    Oct 22, 2013
    #1
    Went to install Mavericks on my Haswell MBA, seemed to download fine, computer restarted, then i got the dreaded install failed screen. Tried restarting many times with no luck, reset the PRAM, no luck, tried repairing in disk utility and was told it couldn't be repaired. Computer was working just fine this morning, so i'm pretty confused. I've found a few threads with similar issues, but not sure what my next step should be? I have a genius bar appointment tomorrow afternoon, but honestly if they're just going to try and swap the drive that's not really an acceptable solution, even though i don't have much on the drive i care about, it's still obviously not a damaged drive so i shouldn't need to lose anything. Any tips or ideas would be great! :eek:

    [​IMG]
     
  2. Velin macrumors 65816

    Velin

    Joined:
    Jul 23, 2008
    Location:
    Hearst Castle
    #2
    Try a clean install via USB. Failing that, if you have another apple computer (desktop, imac, portable) with a FireWire port, you can gain control of that MBA harddrive via Target Disk Mode. You can even wipe the disk and install Mavericks using Target Disk Mode, I've done it many times on Macs that are acting up.
     
  3. BasicGreatGuy Contributor

    BasicGreatGuy

    Joined:
    Sep 21, 2012
    Location:
    In the middle of several books.
    #3
    If the Genius Bar wants to swap out the drive (replace with a new one) and doing so fixes the problem you are having, why would you oppose that?
     
  4. Nathan777 thread starter macrumors newbie

    Joined:
    Oct 22, 2013
    #4
    Well i mean i do have some stuff i'd prefer not to lose from my machine and i didn't bother backing it up or anything, which is my fault of course, but it still seems like there must be another option than wiping it clean. It's not like installing Mavericks irreparably physically damaged the SSD, and certainly the chance of the drive getting damaged in the exact moment of install due to unrelated issues is pretty much zero, so the drive itself is fine i assume.

    I'd be perfectly happy if it just let me boot back into Mountain Lion at this point.
     

Share This Page