Mavericks, Mid 2009 15, EFI 1.6 problem ?

Discussion in 'MacBook Pro' started by paulCC, Nov 20, 2013.

  1. paulCC macrumors member

    Joined:
    Nov 2, 2012
    #1
    Hello:
    I have an Mid 2009 Macbook Pro 15, which I cannot get updated to Mavericks.....


    Here are the details:
    - this computer had issues in the past with replacement HDs ( various WD Blue and Black models ). I had to downgrade EFI to 1.6 to make it work with WD 750GB Black.
    - I have tried in the past OS X 10.8, it failed ( many beachballs afer installation ), so I went back to 10.7
    - now I would like to sell the computer, with a clean Mavericks installation
    - Mavericks install fails, the difference from the 10.8 installation is that the installation itself fails
    - I have even tried an Toshiba 500GB HD from my 2011 Macbook, same failure

    My guess is 10.8 and 10.9 do not play well with EFI 1.6. And I cannot go to EFI 1.7, unless I limit the SATA speed to 1.5 GBPS.

    I am wondering:
    - is there an HD or SSD, where the SATA negotiation can be forced to 1.5 GBPS ? Via jumper settings, or some engineering utility ?
    - any other advise ?

    Thanks, Paul.
     
  2. triplelucky macrumors regular

    Joined:
    Sep 30, 2012
    Location:
    Tucson, Arizona, USA
    #2
    I have an old Mid 2009 MBP 15 with EFI 1.7 and 3GB sata speed. I am using a blue WD 320 in it.

    It runs Mavericks nicely. No Problems.

    i have read of some people having flakey hard drive cables.

    Other than that possibility I’m not sure why your having so difficult of a time with this.
     
  3. paulCC thread starter macrumors member

    Joined:
    Nov 2, 2012
    #3
    Thanks for the reply.

    I spent more time looking this up - there seems to be a lot of reports of problems on some Mid 2009 15 Pro, when replacing the original HDD. The issue is when SATA speed is negotiated by the new disk above 1.5 Gbps.

    Solutions are to replace the SATA cable, or keep running the old 1.6 EFI. Unfortunately, OS X 10.8.3 and later do not work with EFI 1.6.

    I have just ordered a HITACHI HDD, there is a Hitachi Feature Tool which allows the SATA speed to be limited to SATA I/1.5 Gbps. This should allow me to upgrade EFI, and - hopefully - to Mavericks.

    Paul.
     
  4. paulCC thread starter macrumors member

    Joined:
    Nov 2, 2012
    #4
    Problem solved.....

    Hello - just an FYI, if anyone needs this info:
    I have now the Mid 2009 Pro 15 running on Mavericks. Here are the steps:
    - purchased a Hitachi Travelstar Z7K500 - 500GB, 2.5" disk, 7200rpm, 32MB, SATA III drive, installed in the computer
    - downloaded the Hitachi tool posted on macrumors, search for HDDFT10.iso
    - burned a CD from this image using Disk Tool
    - booted the computer from this CD, with an USB keyboard, forced SATA speed to 1.5 Gbps
    - booted from an external drive, installed latest EFI for this computer - version 1.7
    - installed Mavericks from an USB stick.

    There were no errors on the installation, no beachballs so far ( both of each problems were occurring on this computer before )

    I know that the other option was the change the SATA cable. This one is not easy to obtain here in Czech Republic, and the swap is much more involved then the HDD change.

    PaulCC
     
  5. jiangshen macrumors newbie

    Joined:
    Mar 23, 2013
    #5
    WD raptor black 750GB efi 1.6

    Is there any similar tool to force my WD 750GB to use 1.5gbps link speed under efi 1.7?
     

Share This Page