Mavericks Mission Control lag on rmbp

Discussion in 'OS X Mavericks (10.9)' started by Valkyre, Oct 23, 2013.

  1. Valkyre macrumors 6502

    Joined:
    Dec 8, 2012
    #1
    As the title says, i notice that most of the time when I have 2 or 3 windows / apps open and I hit mission control, there is very noticeable UI lag.

    Its not every single time, sometimes it is smooth as butter, but most of the time it is quite laggy.

    Is it the same for most retina macbook owners and is there lag in other devices like cmbp as well?
     
  2. sonicrobby macrumors 68020

    sonicrobby

    Joined:
    Apr 24, 2013
    Location:
    New Orleans
    #2
    I havent noticed any on mine (15" 2012 rMBP highest config), but then again Im using the three finger multitouch gesture and not the actual dock shortcut (as I removed that).

    Just tried it with 8 different programs and no lag whatsoever :D
     
  3. syrem macrumors newbie

    Joined:
    Oct 23, 2013
    Location:
    Austria
    #3
    i have a mba 2012 and also had ui lags when using mission control - i reseted nvram and also reinstalled mavericks, but it did not help - so i used my backup to get back to mountain lion... the lags where just to heavy
     
  4. PSalyer macrumors newbie

    Joined:
    Oct 23, 2013
    #4
    I have a 2012 cmbp 13 that I got in july and it has the lagging that you are describing, launchpad also lags when moving between pages. for example if you only have one page of apps and you try to move to another page by swiping to one side or the other then the launchpad page moves over but then centers it self, with mavericks it kinda just gets stuck to one side. With dashboard I have mine on three finger swipe. So when I do the swipe it goes, sometimes lagging, but say I just want a preview. So I do the swipe and not lifting my fingers I could swipe back the other way and it would exit the mission control, with mavericks it does nothing, I have to lift my fingers in order to swipe back down to exit dashboard. The biggest problem I am having is random short freezes, sometimes even with the little death spiral, then it goes back to what I was doing. And the auto light sensing stuff is not working like before either, some may say better... but it takes a split second longer for the screen brightness image to appear when adjusting the screen brightness manually.
     
  5. Modernape macrumors regular

    Joined:
    Jun 21, 2010
    #5
    After the install I noticed this, but after a subsequent reboot it seems fine now.
     
  6. EssentialParado macrumors 65816

    Joined:
    Feb 17, 2005
    #6
    I've got huge lag when using Mission Control in Mavericks. Basically it won't happen all the time, but if I am using a CPU-intensive app and swipe up to open Mission Control, I experience 2-5 second frozen screen mid-animation. It used to be smooth as butter on Mountain Lion but the lag is so frustrating. :(

    I can't replicate the issue every time though, so can't pinpoint it… Are you guys getting the same thing as me?
     

Share This Page