mavericks not liking my soundcard, any advice please?

Discussion in 'Mac Basics and Help' started by beatfromthesun, Nov 13, 2013.

  1. beatfromthesun macrumors newbie

    Joined:
    Nov 11, 2013
    #1
    Hi all. My setup is a imac mid 2010 21.5, SSD 250GB, 8GB ram, just rebooted and installed Mavericks. The soundcard is a Tascam us1461. Now my soundcard wont work and the drivers on the official site for it are 2010 and thats it. Ive emailed tascam.

    Any advice? Any simular problems?


    Worked fine on lion, leopard etc, really dont want to have to go back to lion. Ive tried all the drivers on the tascam site, the latest one doesnt do anything when I click on the install icon, the other will run and install, but nothing happens. When I run the older ones, the soundcard is actually accepted, driver software installed and comes up, and it shows in the sound properties, I can select it, but the sound still defaults to the imac speakers. I have tried alsorts, restarting etc, so any advice really appreciated here. Thanks
     
  2. maflynn Moderator

    maflynn

    Staff Member

    Joined:
    May 3, 2009
    Location:
    Boston
    #2
    You need to wait for the vendor to release Mavericks drivers, all their latest set of drivers is for Mountain Lion. I'd suggest contacting them to see if they'll release an ETA on the updated drivers.
     
  3. beatfromthesun, Nov 13, 2013
    Last edited: Nov 13, 2013

    beatfromthesun thread starter macrumors newbie

    Joined:
    Nov 11, 2013
    #3
    thanks for the response. its a discontinued product so unless they do that, ive got to downgrade to lion again which is a pain , or sell the unit and buy a new one :mad:. thanks again
     

Share This Page