Mavericks not prompting for password after sleep

Discussion in 'OS X Mavericks (10.9)' started by glhughes, Nov 2, 2013.

  1. glhughes macrumors regular

    Joined:
    Jul 4, 2009
    #1
    I fell asleep last night with the laptop on battery power and the clamshell open. When I woke up, the machine was asleep (screen off, battery status after waking - 94% - indicates it was sleeping all night) but pressing a key woke up the machine and took me straight to the desktop instead of prompting for a password!

    I have been having other power management problems with Mavericks such as it ignoring the timeouts for the screensaver, screen off, and sleep that I had set, but those were minor annoyances.

    If the machine no longer reliably prompts for a password after sleeping that is an enormous security hole on a portable machine.

    This is making me consider going back to 10.8 as I simply cannot trust that my machine will be secure when I close the clamshell or leave it unattended (goes to sleep).

    Has anyone else had this problem?
     
  2. Bruno09 macrumors 68020

    Joined:
    Aug 24, 2013
    Location:
    Far from here
    #2
    See : System Preferences / Security & Privacy : check "Require password...."
     
  3. glhughes thread starter macrumors regular

    Joined:
    Jul 4, 2009
    #3
    Yes, that is the first thing I checked. It is selected.
     
  4. nitropowered macrumors regular

    Joined:
    Aug 25, 2003
    Location:
    Ohio
    #4
    I know this thread is a month old, but I'm having the same issue. Every now and again, when opening my late 2013 rMBP, it does not prompt me for a password. I'd say it works 90% of the time, but obviously that isn't good enough
     
  5. Bruno09 macrumors 68020

    Joined:
    Aug 24, 2013
    Location:
    Far from here
    #5
    System Preferences / Users and Groups.

    Open the lock, select your account, click "Options".

    "Automatic login : Disabled"

    OR (identical) :

    System Preferences / Security and Privacy / General :

    Check : "Disable automatic login".
     
  6. nitropowered macrumors regular

    Joined:
    Aug 25, 2003
    Location:
    Ohio
  7. jpfpreston macrumors newbie

    jpfpreston

    Joined:
    Nov 15, 2013
    Location:
    London
    #7
  8. ermine macrumors newbie

    Joined:
    Jan 27, 2014
    #8
    I am experiencing the same problem. No matter what option I chose the mac will not require password when exiting sleep. It is annoying. It stopped working after upgrading to Maverick.

    And why is it possible to change "Require password" without authentication?

    ----------

    After a restart of the computer it started working. Could this be some issue with App-NAP?
     
  9. efalk macrumors newbie

    Joined:
    Jun 21, 2014
    #9
    Any word on this?

    I just upgraded to Mavericks, and I'm having the exact same issue.

    "Require Password" was already checked.

    I unchecked "Disable automatic login" and was then prompted for my login info. I'm not sure what that means, but at any rate, it was no help.
     

Share This Page