Mavericks on a MacBook4,1 (Early 2008)

Discussion in 'OS X Mavericks (10.9)' started by sega dude, Jul 29, 2014.

  1. sega dude, Jul 29, 2014
    Last edited: Jul 29, 2014

    sega dude macrumors newbie

    sega dude

    Joined:
    Jul 25, 2012
    #1
    I have a MacBook (Early 2008) with a 2.1 GHz Core 2 Duo and 2.5GB of RAM. It runs Mountain Lion via MLPostFactor very well, I am using it right now. I NEED to install Mavericks to be able to use the latest version of Xcode. I tried this guide as well as Sixty Four On Thirty Two but they both resulted in a non-bootable flash drive. I later found out that the MacBook4,1 has 64-bit EFI and therefore does not need a tiamo's patched boot.efi. So I went and put back the original boot.efi files from the BaseSystem.dmg file and attempted to boot the flash drive. This time it did boot from the flash drive, but I got the prohibited symbol. I restarted and booted in verbose mode to see why this was. I got an error that said "This version of Mac OS X is not supported on this platform!" How can I get the drive to boot if I can't use the patched boot.efi?

    EDIT: Got it working. Turns out Sixty Four On Thirty Two corrupted the PlatformSupport.plist and InstallableMachines.plist files. I replaced them with the originals and inserted my board id into each file as well as the Distribution file on OSInstall.mpkg. The installer than booted up just fine and I installed Mavericks no problem. After installing the kexts from jacobpina1's guide, everything worked expect graphics acceleration and sleep. Don't install IO80211Family.kext or Wi-Fi will stop working.
     
  2. flessa macrumors newbie

    Joined:
    Aug 13, 2014
    #2
    Could you provide a guide on how you did it? PVT me if you can, I have MoLo running using MLP, and your assistance in getting mavericks running would be superb for the community.

    I have a black macbook early 2008.
     

Share This Page