Become a MacRumors Supporter for $25/year with no ads, private forums, and more!
  • Did you order new AirTags? We've opened a dedicated AirTags forum.

martinm0

macrumors 6502a
Original poster
Feb 27, 2010
566
25
Microsofts' latest update of RDP for Mac recently brought one of the single greatest features (IMHO): Use All Monitors. This feature lets you use all your monitors on the host PC when remotely accessing another machine (i.e., I can now use dual monitor setup for RDP when the remote PC only has a single monitor attached).

However, after moving to Mavericks I noticed I no longer have this option in the session preferences, though it still exists on my wife's MBA running ML still.

Anyone else notice this, or have any idea why its no longer available?
 

hallux

macrumors 68040
Apr 25, 2012
3,307
870
Likely related to the new way Mavericks handles multiple monitors.
 
Comment

martinm0

macrumors 6502a
Original poster
Feb 27, 2010
566
25
Likely related to the new way Mavericks handles multiple monitors.

That's what I was thinking as well. Its just odd that the setting is completely missing in Mavericks, while the same build (I assume) in ML still has the option. I'd have expected it to be more greyed out but still visible in Mavericks.
 
Comment

aajeevlin

macrumors 65816
Mar 25, 2010
1,210
540
Maybe the next update will have some option to turn it off. This is not just a remote desktop problem, I can already see people using excel wanting to stretch to two or even three screens not able to do that (at least I wasn't able to do that yesterday).
 
Comment

martinm0

macrumors 6502a
Original poster
Feb 27, 2010
566
25
Fixed!

The latest update brought the "Use All Monitors" option back. Love this feature.
 
Comment
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.