Mavericks resolving host wifi problems

Discussion in 'OS X Mavericks (10.9)' started by GideonGideon, Apr 19, 2014.

  1. GideonGideon macrumors newbie

    Jan 5, 2014
    I own a macbook pro retina with Mavericks (10.9.2)
    I recently (last 2 weeks more or less) started experiencing serious WIFI issues.
    About every 5 minutes my MBP is unable to load pages for several minutes. When using chrome I see a "resolving host" message and when using Safari the MBP just doesnt load anything.
    I know for sure its not a problem with the router since my friends use it without any problems and I have a linux and window computers that also have no problems using the WIFI.
    I obviously googled the problem but I could not find anything that actually works
    This is one of those problems you can't live with... it reached the point that I can't use the MBP anymore... this is really frustrating.
    Is there anyway to solve this?
  2. smithrh macrumors 68020


    Feb 28, 2009
    Possible a DNS server issue - there have been DNS issues around the internet for the last few weeks.

    Try a different DNS server. It could be that your friends are not using the same server that you are, so they don't run into the problem.
  3. GideonGideon thread starter macrumors newbie

    Jan 5, 2014
    I already tried changing DNS (I added the and google's DNS servers)
    But its still not working... :(
  4. smithrh macrumors 68020


    Feb 28, 2009
    Have you tried Wireless Diagnostics?

    Access it by pressing the Option key while clicking on the WiFi symbol menu, it's at the bottom...
  5. GideonGideon thread starter macrumors newbie

    Jan 5, 2014
    I've actually never used to Wireless Diagnostics.
    I just ran it for several minutes and it created a report. However I'm not quite sure what to do with the created folder... Could you instruct me on how to proceed from here?
  6. smithrh macrumors 68020


    Feb 28, 2009
    It should have said whether or not the wifi connection was working as intended.

    It is easy to miss - I've missed it myself when running it before.
  7. GideonGideon thread starter macrumors newbie

    Jan 5, 2014
    I re-ran the diagnostics and I keep getting a "Dropped connection detected" (about every 2 minutes)
    Anything I can do?
  8. GideonGideon thread starter macrumors newbie

    Jan 5, 2014
    I tried resetting the router as the diagnosis suggested but it didn't work either
  9. smithrh macrumors 68020


    Feb 28, 2009
    If you have a cable or DSL modem, reset that too.

    Does your web browser still say "resolving?" Again, that points to a DNS issue of some sort as the computer will use a DNS server to resolve the IP address of the website ( ->
  10. pready macrumors newbie

    May 10, 2014
    Try hard-coding your IP and DNS. I had a similar problem and this has solved it.

    All my other devices work fine while my 10.9.2 MBP could not connect (although it could ping just fine).
  11. unplugme71 macrumors 68030

    May 20, 2011
    Enter in a static IP for your MBP.
    Then switch over to the DNS tab, enter the IP address of your router (ie or or

    On your router, use the following DNS servers


    Or manually enter in your ISPs DNS servers, if known.

    Then reboot your computer, and reboot the router. That should hopefully fix your issue.
  12. gura macrumors newbie

    Sep 16, 2014
    resolve wifi problems mavericks

    Had similar problems
    also resolving host issues that forced me to stop en start wifi all the time to solve the issue.

    After consulting apple support, here is my tip:

    - got to finder finder
    - then:

    /go/ macintosh HD/library/ SystemConfiguration

    - Empty content of the SystemConfiguration folder
    - Restart computer

    This folder might contain wrong settings that cause the wifi communication with a router / modem to be unstable. After removing the files from the SystemConfiguration folder the OS will generate a new freshly "calibrated" version of wifi settings that might solve the issue

    Hope this simple action helps.

  13. mlim650 macrumors newbie


    Sep 11, 2010
    I don't see a directory /macintosh HD/library/SystemConfiguration. However there is a /Macintosh HD/System/Library/SystemConfiguration.

    The files in this folder have .bundle file extensions.


Share This Page