Become a MacRumors Supporter for $50/year with no ads, ability to filter front page stories, and private forums.

SSD-GUY

macrumors 65816
Original poster
Sep 20, 2012
1,151
2,104
Interstellar
Hi all

I understand that Safari on Mavericks only supports up to 720p, and do get 1080p/4K etc you need to upgrade to Yosemite, however, only 10.9.5 machine, I only get unto 360p.

Now here's the weird part, if I set Safari to private browsing, the 720p option becomes available (as well as 240p)

Does anyone here know of a fix? I'm on the latest version of Safari available for Mavericks as there are no more updates remaining.

Thanks
 

redheeler

macrumors G3
Oct 17, 2014
8,388
8,770
Colorado, USA
Try this: In Preferences > Privacy, under "Cookies and other website data" hit Details, select youtube.com, and hit Remove.
 

jerwin

Suspended
Jun 13, 2015
2,895
4,651
Some years ago, I had flipped on a Debug optiopn in Safari which essentially disabled anything over 720p. Couldn't figure out what was causing it-- chalked it up to having an old machine, and used firefox when I had a need for higher resolution video.
The bug then followed me to my iMac 5K. At which point, I stated going over those preferences with a fine toothed comb.

I would suggest making a new account-- even one of those Guest accounts, and view a Youtube video--- see you can get high resolution graphics.

Also, check out https://www.youtube.com/html5

This is my result with OSX 10.11.
Screen Shot 10.png


You could always change the user agent to something akin to Firefox's--IIRC, that lets youtube use the flash player.
 

SSD-GUY

macrumors 65816
Original poster
Sep 20, 2012
1,151
2,104
Interstellar
Hi guys,

Thanks for all your replies. I have managed to fix it.

Firstly, I cannot update to the latest version of OS X due to certain programmes that I use (statistical analysis) only being supported at Mavericks at the moment with the licence I've paid for. Anyhow, let's get on to the fix.

Firstly, I made sure I had the latest security updates installed. This allowed YouTube to display at 720P within Safari and using the HTML5 player, however after a restart, the options were gone.

Therefore, I clicked reset Safari, by clicking safari in the menu bar, then clicking 'reset safari'.

I'm happy to report, Youtube at 720p now works.
 
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.