Mavericks Server VPN

Discussion in 'Mac OS X Server, Xserve, and Networking' started by alksion, Sep 16, 2014.

  1. alksion macrumors 68000

    alksion

    Joined:
    Sep 10, 2010
    Location:
    Los Angeles County
    #1
    Trying to Accomplish: Connect my iPad, MacBook Pro, and iPhone to my iMac.
    Specifications: Mavericks Server 3.1.2, iMac 27 Late 2013 Mavericks 10.9.4

    I've followed this video to the tee and keep getting this error message (The L2TP-VPN server did not respond. Try reconnecting. If the problem continues, verify your settings and contact your Administrator.) when trying to connect from any of the devices with my appropriate credentials.

    Everything looks correct in the server app. All system and server updates. All ports opened in my airport extreme.

    Does any one have a clue?
     
  2. mvmanolov macrumors 6502a

    Joined:
    Aug 27, 2013
    #2
    1) is access to your server set up properly? (can you connect to the VPN over your internal network?) is so, check under server menu access settings. this video:https://www.youtube.com/watch?v=eA6rfepKWUs&index=3&list=PLP9lCFXVZfRNJx3S2dqM3h0NEZ5Xto2iZ

    2) is your dns service setup properly? ( open terminal and type: sudo change -checkhostname )

    3) do you have the newest version of the server app, and osx? there were some issues wioht this at the beginning that was preventing l2tp connections software updates have fixed those.

    4) do you have the right IP address/hostname? did you seup a no-ip/dyn hostname updater? does your hostnmae match that in the fns/vpn services

    5) can you connect via pptp from outside? but first check if you can connect l2tp from inside your network,

    ----------

    P.S.

    while todd oltoff isn't bad here are some better resources about mavericks server:

    http://krypted.com/guides/mavericks-server/

    https://www.yesdevnull.net

    good luck mate. it took me a while to learn and figure it all out :D
     
  3. Ripmax2000 macrumors regular

    Joined:
    Aug 31, 2005
    #3
    Make sure Back to My Mac setting isn't setup on the Airport, as well as on any computer on the network (it can override the port VPN needs).
     
  4. alksion thread starter macrumors 68000

    alksion

    Joined:
    Sep 10, 2010
    Location:
    Los Angeles County
    #4
    Thank you for the reply. I will go over each one of these and respond to each one directly when I have a little more time!
     
  5. alksion thread starter macrumors 68000

    alksion

    Joined:
    Sep 10, 2010
    Location:
    Los Angeles County
    #5
    Please see red text for more detail.
     
  6. mvmanolov macrumors 6502a

    Joined:
    Aug 27, 2013
    #6
    sorry this is the command: sudo changeip -checkhostname

    try and and see what it says if its anything but: The names match. There is nothing to change.
    dirserv:success = "success"

    then you have a DNS problem...

    the fact that you cannot connect from your LAN suggests that there may be a fns problem.

    check out the information about setting up DNS here:

    http://krypted.com/guides/mavericks-server/

    and here:

    https://www.yesdevnull.net

    but run the command first.
     
  7. alksion, Sep 21, 2014
    Last edited: Sep 21, 2014

    alksion thread starter macrumors 68000

    alksion

    Joined:
    Sep 10, 2010
    Location:
    Los Angeles County
    #7
    That's exactly what it said. I feel like everything is correct. I don't know what to try next?
     
  8. mvmanolov macrumors 6502a

    Joined:
    Aug 27, 2013
    #8
    did you check if you set this up properly:

    video:https://www.youtube.com/watch?v=eA6r...M3h0NEZ5Xto2iZ

    if so, then in the vpn service the dns should point to your Server's local ip address,

    your AEBS is your router i assume? go into the settings and see if that is forwarding correctly.

    and one last thing, someone else mentioned that here as well (and i didnt see you respond to that), make sure that "back to my mac" is not enabled on any of the machines as that would mess with the VPN server. system preferences > iCloud (scroll to the bottom and uncheck "back to my mac" if checked. repeat on all machines)

    then go into the Airport Utility and manually and check is there are any accounts in the "back to my mac" field at the bottom of the "base Station" tab.
     
  9. alksion, Sep 24, 2014
    Last edited: Sep 24, 2014

    alksion thread starter macrumors 68000

    alksion

    Joined:
    Sep 10, 2010
    Location:
    Los Angeles County
    #9
    [​IMG]
    [​IMG]
    [​IMG]
    [​IMG][​IMG]
    [​IMG]
    [​IMG]
    [​IMG][​IMG][​IMG][​IMG]
     
  10. alksion thread starter macrumors 68000

    alksion

    Joined:
    Sep 10, 2010
    Location:
    Los Angeles County
    #10
    Nothing associated with Back to my Mac has ever been activated and is currently disabled.

    I posted photos, in the best order possible of my current configuration. Please tell me if you see anything that doesn't look right. And again, thank you so much for all your help and taking the time to assist me! :)
     
  11. mvmanolov macrumors 6502a

    Joined:
    Aug 27, 2013
    #11
    ok so a couple of things...

    1) go into your AEBS under the "internet" tab you will see the two DNS fields. in the first field put your server ip 10.0.1.16 in the second tab put the DNS server of your ISP or google 8.8.8.8 or OpenDNS (i forget that but you can look it up).


    2) in the DNS settings on your server: click the edit button for the "forwarding servers" delete and two entries that are there and enter either your ISP's DNS server or Google or Open DNS, (you can enter more than one if you want but i'd start with one first to make sure nothing else is messing up.

    3) in the VPN settings on your server: click the edit button for the DNS settings delete the two entries that you currently have and only put your server's IP address (10.0.1.16).

    4) the DHPC server on your AEBS has been configured to provide ip addresses within the 10.0.1.1 to 10.0.1.100 range but your VPN service starts at 10.0.1.120 to 10.0.1.140: change these to provide 20 addresses within the DHCP range. so for example at the "starting at" field (VPN Server) you can enter 10.0.1.80 (or lower this is your choice) this way you ensure that all the IP's are within the DHCP server range.

    5) your modem, the one the ISP gave you when you signed up is in bridge mode i assume? (you edited it so it does not provide DHCP and NAT correct? only your AEBS provides DHCP and NAT?

    Let me know how it works out... :D
     
  12. alksion thread starter macrumors 68000

    alksion

    Joined:
    Sep 10, 2010
    Location:
    Los Angeles County
    #12
    Okay, I followed everything in your post and I keep getting the stupid error message. I will post it.

    As far as number 5 goes. The modem I purchased through Amazon. It's one of those Motorola Surfboard ones. My ISP activated for me after it was delivered.

    What on earth would be causing it not to connect? :mad: PS: Thank you for all the help! You don't know how much I appreciate it.

    [​IMG]
     
  13. mvmanolov macrumors 6502a

    Joined:
    Aug 27, 2013
    #13
    i'm glad to help...

    there isn't much more that i can think of however, the only other issue may reside if the modem you bough is also a router...

    check the ip address that your AEBS gets and if it starts with a 198 then then modem is the router and it is providing DHCP to the AEBS and NAT.

    after that i don't know how i could help more... perhaps you could call apple support for enterprise as they deal with the server app, and see what they say...
     
  14. alksion thread starter macrumors 68000

    alksion

    Joined:
    Sep 10, 2010
    Location:
    Los Angeles County
    #14
    Sounds good! Thanks again. Do you have any 3rd party suggestions?
     
  15. mvmanolov macrumors 6502a

    Joined:
    Aug 27, 2013
    #15
    no i never needed them my mini server works just fine.

    sorry its behaving weirdly on you...
     

Share This Page