Mavericks Server with Win7 clients: File locked for editing

Discussion in 'Mac OS X Server, Xserve, and Networking' started by woodlandtrek, Jun 20, 2014.

  1. woodlandtrek macrumors member

    Joined:
    Jan 21, 2008
    #1
    Hi all,

    I recently replaced a Snow Leopard server with a 2013 Mini running Mavericks server for a family business. Everything works fine, except for file sharing.

    When one of the users has a file open, it will occasionally get "stuck" open on the server. Any future attempts to edit the file will result in the message "This file is locked for editing by another user". These are mostly microsoft office files, but the problem is not being caused by the typical $~ lock files. It appears to be somewhere in SMB.

    When I run lsof | grep "smbd" | grep "REG" I get no results (when no documents are actually open).
    When I run that same command under sudo, then the troublesome files show up. Restarting smbd fixes the issue temporarily, but then eventually other files get stuck in the same way.

    Any advice? I've tried everything I can think of to figure out what's causing this.
     
  2. satcomer macrumors 603

    satcomer

    Joined:
    Feb 19, 2008
    Location:
    The Finger Lakes Region
    #2
    This happens because most Windows users think if in OS X they click the red menu bar button it will close a running application, but it won't. In OS X you must quit a program to close the program but in OS X the red button means to just close the running window, not to close the program. So a user is still running the offending application file program after they opened a program on the server.
     
  3. joelkadeen macrumors newbie

    Joined:
    Jun 17, 2014
    #3
    Usually things like that need a password to unlock or it was saved under a different user name. Try simply saving the file under a slightly different file name and try working from that copy.

    difference between virus and trojan horse
     
  4. iRATs macrumors newbie

    Joined:
    Sep 12, 2008
    #4
    Same Problem

    I had this same exact issue. I've done a lot of research and contacted apple support :apple: but no resolution. Most of the research points to the upgrade from SL to Mavericks server. I plan to do a fresh install, recreate Open Directory and move the files back to the server cleanly. If that does not solve the issue I'm stumped.

    Something to consider for the upcoming Yosemite also.

    Has anyone else had this issue? Any resolution?
     

Share This Page