Mavericks slow booting up

Discussion in 'OS X Mavericks (10.9)' started by comics addict, Oct 15, 2013.

  1. comics addict macrumors 6502a

    Joined:
    Feb 16, 2013
    #1
    I just upgraded my machine to the OS X Mavericks GM and have noticed that boot-up has gone from 9 to 20 seconds on my SSD. Shut down however seems to have shorten to less than 10 or so. Anyone else experiencing this ? :confused:
     
  2. coldjeanzzz macrumors 6502a

    Joined:
    Nov 4, 2012
    #2
    restart a few times and see if it stays at 20 seconds

    i thought mine was slow too but after a few restarts it's now back in the 12-13 second range which is what it was on ML
     
  3. comics addict thread starter macrumors 6502a

    Joined:
    Feb 16, 2013
  4. GP-SE macrumors 6502

    Joined:
    Feb 27, 2013
    #4
    it's slower than ML for me also, but only about 5-6 seconds slower, so not that much.
     
  5. xgman, Oct 16, 2013
    Last edited: Oct 17, 2013

    xgman macrumors 601

    xgman

    Joined:
    Aug 6, 2007
    #5
    Clear the kext caches:

    sudo chown root:admin (enter password)

    sudo kextcache -system-prelinked-kernel
    sudo kextcache -system-caches


    Do in terminal and reboot. make sure your start up disk is still selected correctly in preferences.
     
  6. MeUnix macrumors 6502

    Joined:
    Aug 21, 2013
    Location:
    San Francisco
    #6
    On my MacBook, Mavericks GM boots up in about 14-15 seconds. A *little* slower than Mountain Lion booted up on the same machine.


    - Kyle
     
  7. ibarnett macrumors regular

    ibarnett

    Joined:
    Aug 20, 2010
    Location:
    Gold Coast, Australia
    #7
    Great tip!
    I also had a slower start-up, this solved the problem, thanks!
     
  8. comics addict thread starter macrumors 6502a

    Joined:
    Feb 16, 2013
    #8
    Then I'll also have to try out xgman's tip and report back.
     
  9. dsciel macrumors regular

    Joined:
    Jul 13, 2011
    #9
    this works!!
     
  10. djtech42, Oct 16, 2013
    Last edited: Oct 17, 2013

    djtech42 macrumors 65816

    djtech42

    Joined:
    Jun 23, 2012
    Location:
    West Chester, OH
    #10
    Whoa! I didn't even have a slow boot up, but this still improved the boot up time. It's around 8 seconds!
     
  11. micke1967 macrumors member

    Joined:
    Nov 1, 2012
    #11
    Hi I dont have much experience with the terminal...
    could you explain step-by-step how to do this??
    I understand I need to open a terminal window but then what??
    best regards
     
  12. Krazy Bill macrumors 68030

    Krazy Bill

    Joined:
    Dec 21, 2011
    #12
    1.) Open Terminal. Copy/Paste this line to the terminal window:

    Code:
    sudo kextcache -system-prelinked-kernel
    2.) Press Enter. Type your OSX password to allow changes. Wait for cursor.

    3.) Copy/Paste this line to the terminal window and press Enter:

    Code:
    sudo kextcache -system-caches
    4.) Quit Terminal. Reboot.
     
  13. micke1967 macrumors member

    Joined:
    Nov 1, 2012
    #13
    Hi Many thanks I will try this as soon as mavericks is out and ive installed it...great:)
     
  14. xgman macrumors 601

    xgman

    Joined:
    Aug 6, 2007
    #14
    sometimes you first have to type sudo chown root:admin and the enter/your password

    I find it's not a bad idea to run the above cache clearing commands every so often.
     
  15. lapy macrumors newbie

    Joined:
    Jun 4, 2013
    #15
    my rMBP 2013 i7 2.7ghz 16gb ram is slower booting up with Mavericks GM too, I never saw the spinning gear on Mountain Lion when booting up and now it goes for at least 5 seconds. It's not a huge deal but it seems to be a sign that there's something wrong. I already tried to clear caches etc. No change. And my system is kinda clean, just a few big applications installed like Office and Photoshop, all the rest are small apps from the App Store (no new apps since I switched to Mavericks).
     
  16. cwpics macrumors newbie

    Joined:
    Aug 8, 2013
    #16
    Having similar issues on a my new mba. Cleared the cache etc but it's acceptable by any means.

    Still can't believe it's free!
     
  17. djoliverm, Oct 23, 2013
    Last edited: Oct 23, 2013

    djoliverm macrumors newbie

    Joined:
    Oct 21, 2013
    #17
    My MBPr is taking MINUTES to boot

    Hey guys, wondering if anybody else got this problem, but my MBPr is taking several minutes (about 5 minutes last time I timed it) to boot. It does boot eventually. I did a clean install and used migration assistant on a backup and deselected copying System settings. (On the final public release from the Mac App Store btw.)

    I just did a safe boot to clear the dynamic loader shared cache, which took several minutes, and upon getting to the login window I immediately restarted the system. The following restart was very quick, like 5 seconds.

    I then rebuilt the kernel extension caches like in this post, and again the boot up took several minutes. I then restarted and this time it was quick again.

    I decided to then try a boot from a complete shutdown and I'm back again to it lasting several minutes. What could possibly be wrong? Any suggestions?

    EDIT (Possibly fixed?): So after the initial boot I tried a series of successive restarts and they all clocked in at around 15 seconds total, so normal. And I just tried a boot from shutdown and it's back to normal as well. So fingers crossed it stays like this. Weird. Thanks for the post guys.
     
  18. MikeDVB macrumors newbie

    Joined:
    Dec 2, 2010
    #18
    I'm having the same issue on Mavericks on a brand new [Late 2013 Edition] 15" MacBook Pro Retina.

    It usually [9 times out of 10] takes roughly 2 to 3 minutes to get me to a log-in screen.

    If I boot into safe mode and then shut down and boot normal it boots in a few seconds [very quick].

    If I shut down from 'normal' mode and boot back up it takes 2 to 3 minutes to boot.

    From the logs it looks to me like the boot cache is failing on every boot and being rebuilt [and loaded] which takes time - every time.

    Have done a format/erase + fresh install twice now - issue persists.

    Have an open ticket with Apple and it's in their Engineering department now. I believe this to be a bug with Mavericks but can't confirm this 100%. They do not believe it's hardware failure nor do they believe it's a software issue. Disk Utility tools all ran - etc.

    For me the solution is simply to use sleep [and turn off power nap] until the system boots quickly every time as I'm used to.

    Perhaps a reboot every couple of days to keep things 'fresh' when I'm not in a hurry to use the system.

    I imagine with all of the changes in Mavericks they're probably being slammed with bug reports. I just hope 2 to 3 minute boot time on a machine that should take seconds will be prioritized if it is a bug.
     
  19. djoliverm macrumors newbie

    Joined:
    Oct 21, 2013
    #19
    Does it hang on one particular line, especially the one I've referenced elsewhere in this thread? Can you boot in verbose mode and see in real time where it hangs? If it hangs at the exact same spot/error then that's interesting. Thing is that I don't think it's a huge problem since it doesn't seem to be a lot of people complaining about it.

    Anyway, thanks for your input. Tomorrow I think I'm starting from fresh (no migration assistant) and I'll see how it performs literally right after a brand new install (although you've already tried twice and no luck). I'll also file a report.
     
  20. mrleonhuang macrumors newbie

    mrleonhuang

    Joined:
    Oct 23, 2013
    Location:
    Washington DC
    #20
    Yes, I am facing this problem, too. When I used the Mavericks GM1, everything was good. But when I downloaded the formal version from App Store and installed it, my boot up time is several minutes. I also tried every method I could use, trying to fix it, such as reinstall, reset NVRAM, PRAM and other terminal input methods, none of them could fix it.

    By far, I have seen 3-4 users face to this problem, I also think that it is a bug of the new system since the problem did not even happen when I used Mavericks GM! I have totally no idea about how to fix it because I have tried every method already. Hopefully, this problem can be solve when system updates are available. I will keep track of the forum and pay attention to you guys' feedbacks.
     
  21. ooo macrumors 6502

    Joined:
    Nov 23, 2007
    #21
    Call yourself lucky 2-3 minutes... it's taking me 5-10 minutes on 15" MBPR (late 2013 model). What happen is my finder will freeze, so I'll try to restart my computer, this process takes forever so I end up force quitting my computer, then bootup becomes a pain...
     
  22. Mave10.9 macrumors newbie

    Joined:
    Nov 10, 2013
    #22
    I have a mbp 13" mid 2010 with crucial m500 120gb in the hdd's bay with the clean installation 10.9 in it. And what about this? I have some troubble on graphics:

    https://www.dropbox.com/s/pitha5m6sb60mkl/V%C3%ADdeo%2008-11-13%2018.58.02.m4v
     
  23. Jabersky macrumors newbie

    Joined:
    Dec 25, 2013
    #23
    2.5 Min Startup

    I am also having a 2.5 min startup on my new 16G i7 Macbook Pro.:mad::mad::mad:
     
  24. Jabersky macrumors newbie

    Joined:
    Dec 25, 2013
    #24

    This, so far, has fixed my new Macbook Pro - although I have only rebooted twice....

    It appears to be an issue with external Western Digital hard drive. I am running a WDD MyBook Velociraptor external drive drive and after booting in verbose mode and doing some digging I did the following.

    Three steps:

    1) I deleted the "folders" folder in /var/folders (sudo rm -r folders)

    2) Go to System Preferences > Users & Groups > Login Items and remove the "WDD..." application from the list.

    3) Restart
     
  25. CaMeL78 macrumors newbie

    Joined:
    Dec 28, 2013
    #25
    booting up time: > 6 min

    Hi guys

    I have the same problem.
    Just got a new Mac book pro last week.

    Problem not solved so far...

    anyone a quick solution that works?
    any news on that issue?

    thx a lot
     

Share This Page