Mavericks Spamming /private/var/logs/asl/

Discussion in 'OS X Mavericks (10.9)' started by Riemann Zeta, Oct 6, 2013.

  1. Riemann Zeta macrumors 6502a

    Feb 12, 2008
    In 10.8, you can set up the configuration in /etc/asl.conf such that applications won't constantly write to the system logs (particularly the folder /var/logs/asl/) every second. However, Mavericks seems to completely ignore any settings in the apple system log config file (asl.conf) and defaults to spamming the log files like crazy. Anyone have any idea what changed with respect to the log system and asl manager?
  2. junkster macrumors regular

    Nov 6, 2006
    I installed Mavericks last night and noticed the same thing. There's way too much trivia and noise in the log files, and asl.conf is ignored (even though there's a non-empty asl.conf by default).

    I suspect there's a setting in /System/Library/LaunchDaemons/ to change this, but I haven't had time to track it down.
  3. junkster macrumors regular

    Nov 6, 2006
    Okay, I fixed this. For whatever reason, everything after one line in the asl.conf file was being ignored, even though I hadn't changed that file since before upgrading to Mavericks.

    I found this by dumping the list of active rules via syslogd.
  4. audio_inside macrumors regular

    Oct 7, 2003
    Boulder CO
    In Mavericks 10.9.5 I was able to turn off the huge volume of diagnostic and performance messages filling up the Diagnostics log that have the form:

    I suppressed these particular messages by editing the asl file /etc/asl/ The line

    store_dir /var/log/DiagnosticMessages
    was replaced by

    store_dir /dev/null
    and voila!, no more superfluous performance logging data clogging up my log file. (Believe me, I was NOT going to enable reporting of this data back to Apple anyway!)

Share This Page