Mavericks & Synology NAS - just mount my shares...

Discussion in 'OS X Mavericks (10.9)' started by GreggyNL, Sep 10, 2014.

  1. GreggyNL macrumors newbie

    Joined:
    Sep 10, 2014
    #1
    :mad: So, got here as final resort... I do not where to look or solve my issue. I'm getting mad of the following, hope you can help.

    Got a Macbook Late 2008 unibody. Recently replaced the HDD with a 1TB hybrid. Did a clean install of Mavericks.
    I also have a Synology Diskstation DS211j with 2x2TB in RAID1 containing all my files.

    Connecting my MB running Mountain Lion connecting to my shares on the Synology at the time worked just fine. With Mavericks it's all dead.
    I know about SMB2 changes by Apple etc... But there is more to it in my case I'm afraid.

    My attempt (all failed) to connect from my MB to my Synology:

    1) In Finder, I can see my server. When clicking on a share as guest on the Synology I get the error: "The operation can't be completed because the original item for music can't be found.".

    2) Same as above now with 'Connect as user' which would be my Synology user which always worked. Same error message.

    3) In Finder: Go, Connect to server: whether I use CIFS, SMB, AFP, IP addresses of hostnames, the window wiggles and I cannot connect.

    4) Add share in Users & Groups, Login Items: I cannot add the shared folder as the Add button is greyed out...

    I read a whole lot about this. Where do I go wrong...?

    Troubles started with Mavericks. All help is welcome!!!

    Cheers,
    Greg
     
  2. Cablekevin macrumors member

    Joined:
    Jul 2, 2014
    #2
    Is the issue still occurring with another SMB server? I've got an rMBP 15" with an Synology D212+ and all is fine, even after reinstalling. Did you do anything to your NAS while reinstalling OSX? And on your nas is WFS/MFS enabled?
     
  3. GreggyNL thread starter macrumors newbie

    Joined:
    Sep 10, 2014
    #3
    Hi Kevin, no I did not change anything on the NAS. I assumed it just would work but somehow automounting does not work (I read a lot about this) and/or it is telling me about invalid permissions (which always were ok).

    It has something to do with that automount. I'm more than happy to go back to SMB if SMB2 does not work. Anything will do... I do not care anymore.

    But every attempt blocks me and I really do not know where to look or who to blame... :mad::mad::mad::mad::eek:
     
  4. satcomer macrumors 603

    satcomer

    Joined:
    Feb 19, 2008
    Location:
    The Finger Lakes Region
    #4
    Instead of using the smb connection use cifs:// instead. This will force SMB1 connection.
     
  5. GreggyNL thread starter macrumors newbie

    Joined:
    Sep 10, 2014
    #5
    Thanks satcomer, but see point 3: already tried that with the error.... :mad:
     
  6. GreggyNL thread starter macrumors newbie

    Joined:
    Sep 10, 2014
    #6
    No one? Really? Am I the only one with this problem? Crap... :eek:
     
  7. geoff5093 macrumors 68020

    geoff5093

    Joined:
    Sep 16, 2014
    Location:
    Dover, NH
    #7
    I also have two MacBook Pros running 10.9 as well as a Synology DS1513+. I have zero issues. I have a shortcut on my dock to one of my NAS folders, when I click on that icon it mounts the share point using AFP. I tried using AFP, SMB, and FTP, all work perfectly fine. I use my external FQDN name which works at home on my LAN, as well as at work over the internet.

    The only thing I can remember is I had to set the group permissions to what you see below to get offsite access to work.

    [​IMG]
     
  8. GreggyNL thread starter macrumors newbie

    Joined:
    Sep 10, 2014
    #8
    ****************** SOLVED ****************

    All,

    Finally got it... I could fix my long lasting issues like:

    "The operation can’t be completed because the original item for “Foo” can’t be found"

    with the following easy steps:
    (run as root or)

    sudo chgrp admin /Volumes
    sudo chmod 775 /Volumes

    It just changes groups and the permissions. Superb!!!!!

    Duh...

    Got it from: http://apple.stackexchange.com/ques...because-the-original-item-for-foo-can-t-be-fo
     

Share This Page