Mavericks takes for ever to run!

Discussion in 'OS X Mavericks (10.9)' started by rei101, Apr 11, 2014.

  1. rei101, Apr 11, 2014
    Last edited: Apr 11, 2014

    rei101 macrumors 6502a

    Joined:
    Dec 24, 2011
    #1
    Hi

    I have a 2010 iMac and I installed the latest update of Mavericks and it takes for ever to do anything. I have to wait 2 minutes to see whats inside a folder.

    I restarted with rebuilding the PRam. I ran disc repair from an iMac via firewire target disc mode.

    From target disc mode I can open all the files just fine, so is not a problem with the hard drive. I ran disc repair and it resolved some issues but not a big deal.

    It seems is a problem indexing everything. But I saw the Spotlight and is not indexing anything.

    I left it running overnight because yesterday started like that after I installed Compressor 3.5 from the Final Cut Studio. I have several computers running FC7 and no problem at all.

    I even started to force quite several times from the console but nothing... the computer is slow.

    The hard drive is running all the time like looking for things.

    Any help?

    Thank you guys.

    ---

    Doing a search it seems is Spotlight, I am going to shut it down from Terminal.
     
  2. jeremysteele macrumors 6502

    Joined:
    Jul 13, 2011
    #2
    If there's one task causing issues you may be able to track it down via Activity Monitor. Apple finally joined the 21st century and added a real disk activity monitor to it.

    Just because you can view files doesn't mean the HDD is fine. It *could* still be an HDD issue. Sometimes before they die they can act incredibly slow - usually the result of the drive trying to correct errors. If spotlight is acting up it could be making it worse.

    by "I installed the latest update" I'm guessing you mean updated from 10.9.1 to 10.9.2? It ran 100% fine before?

    Or do you mean you just installed Mavericks? Was it clean (start from nothing) or in-place (apps/user are kept in place)? If it wasn't a clean install - then try doing that (make sure your files are backup up first so you can copy them back over!!)
     
  3. ZVH macrumors 6502

    Joined:
    Apr 14, 2012
    #3
    That could be a lot of stuff.

    First, how much memory do you have installed? 4GB seems to be the minimum for Mavericks.

    Second, how much free disk space do you have? If you have less than 10GB of free disk space, you'll be in trouble.

    Third, regarding Spotlight indexing, you can download a free tool for monitoring mds indexing in the link below. mds is the process that indexes your system. Go to the bottom of the page and click on the "Get Spot-O-Meter" button (or whatever it's called). Just read the page and you'll figure it out. Here's the link:

    http://scsc-online.com/SpotOff.html

    If mds is over active, that thing will be constantly jumping from the yellow to red range with a few drops now and then into the black and green zones.

    As an FYI, if you've got Time Machine connected to your system, it will mds will go ahead and index and from what I can tell, it can't be controlled. The utility, mdutil can control indexing for Spotlight, but it can't stop it for Time Machine, it has no effect.

    You may seriously just need to be patient and let indexing finish, if that's the problem. If you have huge volumes it might take up to a day to index everything. If the problem is too little memory, you just need to get more. If you're running out of disk space, delete some files.
     
  4. rei101 thread starter macrumors 6502a

    Joined:
    Dec 24, 2011
    #4
    Well, I left the computer indexing like for 3 days and now it works just fine. But really... it took about 3 days.
     
  5. ZVH macrumors 6502

    Joined:
    Apr 14, 2012
    #5
    Me thinks Spotlight, Time Machine, and MDS indexing need some work...and have for years. This is probably also why some people end up buying SpotOff.

    In any case, if you add or subtract volumes, don't be terribly surprised if it starts its indexing all over again. It seems to me that in Snow Leopard and Lion it did updates to the index files that would only run for a few minutes. With Mountain Lion and Mavericks, any time something is changed, it acts like it's re-indexing everything from start to finish, all over again. I've had it run for 8 hours on my system, and it's annoying.
     

Share This Page