Mavericks won't allow internet sharing?

Discussion in 'OS X Mavericks (10.9)' started by MiMiN, Nov 10, 2013.

  1. MiMiN macrumors newbie

    Joined:
    Dec 22, 2011
    #1
    Hey guys,


    Since updating to Mavericks, it won't let me broadcast my internet connection in my room/flat the way Lion did. As in, I turn on Internet Sharing (with Wi-Fi) checked and it asks me with a prompt whether I am sure, I say yes and it still doesn't give me that broadcasting icon up in the taskbar.

    Any help?
     
  2. Bruno09 macrumors 68020

    Joined:
    Aug 24, 2013
    Location:
    Far from here
  3. MiMiN thread starter macrumors newbie

    Joined:
    Dec 22, 2011
    #3
  4. murdock1234 macrumors newbie

    Joined:
    Oct 15, 2007
    #4
    Please check the logfile under /var/log/wifi.log

    What does it say?
     
  5. the3rdParty, Feb 18, 2014
    Last edited: Feb 19, 2014

    the3rdParty macrumors newbie

    Joined:
    Jul 5, 2010
    #5
    Same problem

    I am trying to share an internet connection from a USB modem attached to a MacBook Pro (Mid 2012) to other devices via WiFi, and just cannot get Mavericks to cooperate.

    On the MacBook I am doing the following:
    1. make the internet connection on the USB modem
    2. turn on wireless (there are no networks around)
    3. open sharing preference pane. Click "WiFi Options" and define the network name, channel & security.
    4. ensure that the "share your connection from" correctly indicates the USB modem
    5. click the internet sharing tick box

    I then get asked if I want to turn on internet sharing, and click 'start'. I would expect the wifi symbol in the menubar to change to a solid grey sector with a vertical arrow, indicating internet sharing, but this doesn't happen.

    I have checked the logfile at /var/log/wifi.log and it has no entry for today....

    Any ideas?
     
  6. marcosdipaolo, Apr 9, 2014
    Last edited: Apr 9, 2014

    marcosdipaolo macrumors newbie

    Joined:
    Apr 2, 2013
    #6
    My case is differnet since i receive internet from Airport WiFi and send it to a pc trough an ethernet cable.
    Worked like a charm until Mavericks

    10/04/14 02:04:24,835 com.apple.InternetSharing[6270]: bind(bootps 67): Address already in use
    10/04/14 02:04:24,836 com.apple.InternetSharing[6270]: error creating internal interface for devname bridge100@0: Address already in use
    10/04/14 02:04:24,842 configd[20]: *** Non-configd process (pid=6270) attempting to modify "Setup:/Network/Service/0A8017E5-332C-48E0-9314-3E2502AE94D1/IPv4" ***
    10/04/14 02:04:24,842 com.apple.InternetSharing[6270]: no bridge interface to service en0
    10/04/14 02:04:24,842 com.apple.InternetSharing[6270]: unable to create service for en0
    10/04/14 02:04:24,842 com.apple.InternetSharing[6270]: _start "en0": Operation not supported by device
    10/04/14 02:04:24,842 com.apple.InternetSharing[6270]: *** no external service
     
  7. yjchua95 macrumors 604

    Joined:
    Apr 23, 2011
    Location:
    GVA, KUL, MEL (current), ZQN
    #7
    In my case, it sometimes works and it sometimes doesn't. Happens to ALL my Macs running Mavericks.
     
  8. isa56k macrumors newbie

    Joined:
    May 13, 2014
    #8
    I'm seeing exactly the same on my mac running mavericks too.. I have posted here:

    https://discussions.apple.com/message/25772972#25772972

    Maybe someone at Apple will pick it up...

    Seems odd as there is no bridge100 interface at all, if you create a bridge100 the error increments to bridge101@0 not sure of the significance of @0 I guess it is some bad code some where maybe :/

    I also use hands off and little snitch, a colleague has little snitch installed and has no issues sharing connection.

    :mad::mad::mad::mad::mad:

    thx//56k
     
  9. jls2k5 macrumors newbie

    Joined:
    Oct 23, 2014
    #9
    Simply open "Activity Monitor", then force close "bootpd"

    Try internet sharing again.

    This solve my problem :)
     

Share This Page